Radio malfunction - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-10-17, 03:43 PM   #1
Junior Member
 
Join Date: Oct 2017
Posts: 1
Smile Radio malfunction

Hello! I have a problem with my Peugeot 406 RD3 radio unit (stock - Clarion)

Keep in mind - this is a radio from a different 406 vehicle
I have recently changed my old radio. Therefore I had to change the VIN number. (So the beeping would end).

For the actual question:
A problem has occoured, my radio won't turn on! (and there is no signs of communication between the radio and the multifunction screen). However it is possible to eject/insert CDs, but there is still no sound what so ever. Therefore I know that the unit draws power. I have checked the fuses as well, and none are blown.

I tried to run a diagnose (global test) through PP2000, and went into the radio configuration. From there, the radio suddenly started to play. I managed to switch channels aswell. But the volume dimmer didn't work, as well as there was no communication between the radio and the mutifunction screen. Keep in mind that this happend when the car was hooked up to PP2000.

I appreciate all the answers I get, hopefulle someone knows what's wrong.

If I can't get the radio to work, I will try to find another radio at the local scrapyard. Maybe the problem is within the unit itself.
aleksanderer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-10-17, 07:51 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,043
Default

The radio is most likely faulty the power switches break on them sometimes try holding it in much harder than normal see if it turns on.

Planet overrides the power switch enabling it to turn on try again with planet and use the stalk controls to turn up volume if it then works the switch on the facia is faulty
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:15 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.