Peugeot 406 HDI 2004 electrical problem - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-16, 01:38 PM   #1
Inactive User
 
Join Date: Jun 2016
Posts: 2
Default Peugeot 406 HDI 2004 electrical problem

Hi,
Any ideas welcome? I left the ignition on and flattened the battery. After recharge the ABS light stayed lit when engine running and clearly the ABS was not working when tested on the road. Other than that the car ran perfectly. However after a few days we noticed the engine did not cut after switching off unless in reverse gear. Even then some aspects of the ignition would at times stay on, but not the ignition light. eg. central dashboard screen information, humming noise from behind dashboard and reversing lights. We have now noticed a second turn off with the key will at times also cut the engine. Sometimes only a stall will work.
All the faults appear to stem from leaving the ignition on and flattening the battery.
Douglas is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-06-16, 02:10 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,026
Default

I had similar issues with dash display staying lit and not turning off properly but was on older model which had a fan relay unit behind passenger foglight i dont know if your car would have this unit.

My box was full of water this was caused by my wife hitting a deer a few months before and it must have cracked the case allowing the water in it sounds like you have a similar gremlin although it could be another part causing it.

Do a bsi reset and it is unwise to allow the battery to go flat on 406s as they can loose their key codes.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 04-06-16, 04:38 PM   #3
Inactive User
 
Join Date: Jun 2016
Posts: 2
Default

Quote:
Originally Posted by reliable406 View Post
I had similar issues with dash display staying lit and not turning off properly but was on older model which had a fan relay unit behind passenger foglight i dont know if your car would have this unit.

My box was full of water this was caused by my wife hitting a deer a few months before and it must have cracked the case allowing the water in it sounds like you have a similar gremlin although it could be another part causing it.

Do a bsi reset and it is unwise to allow the battery to go flat on 406s as they can loose their key codes.
Hi Reliable406,
Many thanks for a very prompt reply. I have done the BSI Reset. Problem solved in it's entirety.
Best wishes,
Douglas
Douglas is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:17 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.