Injection pressure issues - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree2Likes
  • 1 Post By WillNZ
  • 1 Post By windy1603

Reply
 
LinkBack Thread Tools Display Modes
Old 29-11-18, 09:59 PM   #1
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default Injection pressure issues

406HDi 2001 model, so earlier single plug ECU. RHY 110kw motor. Bosch fuel injection system.

Problems: Engine is quite lumpy when starting, only settles down to a smoothish idle after about a minute. Also not grunty like my other 406's, have to change earlier on hills.

Scanned with PP2000, no fault codes.
Live readings showed fuel pressure at idle was fluctuating a lot. Seemed to try to be at 290bar but dropped as low as 260 bar and jumped to 340bar. At 5000rpm it only gets to 800bar. Should be around 1300bar iirc?

Replaced fuel filter. No change in readings. Pump in tank is supplying a good volume of fuel, have not checked the pressure supply from it though. There is also no visible air in the fuel supply and the leak off test only produced the odd tiny bubble during the entire run.

Did leak off test. Ran motor for 3 mins at idle with 2 runs of 30 secs at 3500rpm in the 3mins. Leak off measured for injectors was 41mm-40mm-34mm-37mm so all good there. [I think the injectors should only leak off 10mm /min if good...??]

Changed FPR for known good one [off another 406 which I tested with PP2000 and pressures at idle were steady at 294bar]. No real change to fluctuations of diesel pressure at idle. Also no change to pressure at 5000rpm. Still maxing out at 800bar.

Changed common rail pressure sensor for one off same donor as FPR, no change in readings.

So it is looking like the HP pump is not performing..? Before I go down the road of replacing it, are there any knowledgeable folk out there with anything else I could check/change to fix the issue? Would be VERY grateful if I dont have to swap out the hp pump..
WillNZ is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-11-18, 10:06 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,026
Default

Check the 3rd piston deactivation status in planet as sounds like that may not be letting the pump get up to full pressure 3rd piston only pumps as required.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 29-11-18, 10:36 PM   #3
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

Will do! Forgot about that...

What pressure should the pump reach at 5000rpm? A couple of other forums [google search] seem to suggest around 1300bar but have found other conflicting advice so not sure.
WillNZ is offline   Reply With Quote Quick reply to this message
 
Old 30-11-18, 06:02 AM   #4
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,501
Default

Max rail pressure is approx 1300 bar unless remapped and at idle it's around 400-500 bar. If you have diagbox it shows expected figures

Sent from my SM-T310 using Tapatalk
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)

Last edited by windy1603; 30-11-18 at 06:04 AM.
windy1603 is offline   Reply With Quote Quick reply to this message
Old 04-12-18, 05:45 AM   #5
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

Update.

Decided to check live readings on some of my fleet of 406's [have far too many ] that run well to confirm what outputs they have wrt pressures at idle and full throttle.. came up with 290-300bar at idle and 1320-1350bar at full power/4500rpm while being driven. Simply revving the engine to 5000rpm while parked- the pressure maxes at 800bar.

Back to problem car... after the above I had a dig around in the engine ecu diagnostic of PP2000. Went to the manual settings section and looked at the injector option. Found that the injectors were loaded in there as not re-centred. Checked the markings on the injectors and they were labelled Y. Changed the injectors to "injector re-centered reclassified 2/B/Y''. Started the car and problem solved. Idle pressure steadyish at 290bar, full throttle on the road 1320bar and idling straight after starting cold is smooth and at 800rpm. Power on the motor is vastly improved. Pulls like all the others now. Happy..
rwb likes this.
WillNZ is offline   Reply With Quote Quick reply to this message
Old 04-12-18, 03:02 PM   #6
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,501
Default

Looks like 406 has lower idle pressures than 307. (No I was wrong I was thinking of Delphi on my DS5) 300 Bar is correct idle pressure

The lower pressure on free revving is due to lower boost level so injection map only demands lower rail pressure and injected fuel qty via smoke map.

Happy to post 307 rail pressure map if it's any good to you (Added to Post)

Sent from my SM-G935F using Tapatalk
Attached Thumbnails
rail-pressure.jpg  
WillNZ likes this.
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)

Last edited by windy1603; 04-12-18 at 05:53 PM. Reason: Updated Info and added Map data
windy1603 is offline   Reply With Quote Quick reply to this message
Old 04-12-18, 08:49 PM   #7
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

Cheers! Is the map for the 90hdi or the 110? Reason is I have a 307 90hdi that is remarkably underpowered and seriously needs a remap/addition of intercooler/change of turbo etc.. have not yet got round to investigating what I can do to give it more get up and go.
WillNZ is offline   Reply With Quote Quick reply to this message
Old 04-12-18, 09:03 PM   #8
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,501
Default

It's from a 110 RHS engine

Sent from my SM-T310 using Tapatalk
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:53 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.