Handbrake warning light coming on (periodically)... - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-03-14, 02:07 AM   #1
Inactive User
 
Join Date: Jun 2013
Posts: 23
Default Handbrake warning light coming on (periodically)...

Back story: The cigarette lighter of my 2000 406 has been giving me issues for a long time (since I bought it, but I already knew about it).
It supplies power in a very specific place, and I usually have to spend a few minutes finding that one sweet spot. Should I be so unlucky needing to reverse, it's very possible that the stick will knock it out of position.
...And then I need to spend a few minutes finding that sweet spot again, as I use the 12v to charge my phone (on longer trips).

Anyway, I ripped it out, went to a store and got a very cheap basic outlet:

However, since there were different connectors (the one in my car is a square "clip on"), I'll have to fuse the wires. That's no problem, but I have to open the entire centre console to get to the wires, so I just left it disconnected for the time being, as my sister and I were going out. I was driving her to the shops and such.

However, and this is where the problem begins...
I back out of the garage, and I see the handbrake warning light is on!
It has happened before, that I haven't disengaged it properly (the light comes on before it's *clicked* once). This is not the case now. Every single time I disengage the handbrake, the warning light disappears for half a second, then comes on with a beep.
I check the brake fluid, that was okay. Full up, as it has been since I did a full service this previous summer. (Well, 1-2 mm below the "max" mark)
Smooth braking and hard braking is fine, as it should be. ABS works as it should. Handbrake works as it should. There's no dragging or anything to indicate the brakes are locked. No weird sounds, acceleration is normal, the car doesn't drag to one side when I brake, smoothly or harshly...

I call my usual garage (a Peugeot certified dealer/garage in the nearby city), and they tell me that if the brakes work as they should, the fluid level is between min and max, and the handbrake works as it should, there shouldn't be any issues driving with it. (they know my car too) However, I could take my car there and have they take a small look at it.
So, I do.

The guy I talked to earlier says he has thought about it, and that on some of the older cars, a pressure switch on the handbrake itself could be broken or malfunctioning, which leads to this error. Especially since everything else works fine.
He has one of his trainees (at least I hope he was a trainee) swap it out... Which takes 45 minutes. After which, the problem persists.
So they hook up the Peugeot Partner 2000-program pc-thingy, but no problem is reported.
After which, the guy I originally spoke with (he double checked the pressure switch and the diagnostic program) said that the problem was most likely electric, a bad conductor/cable somewhere.

I am thinking the same thing, especially with what happened today and yesterday when driving to and from work...
When I drove home yesterday, on the entire 20 minute drive, the warning light only came up when I had the handbrake engaged... It did not behave as it had did. Same thing when I went to work today. Nothing... Even though I tried to force the reaction by pulling the handbrake up slightly, then putting it down again.
But, when I drove home from work, there it was again...

Now, I haven't gone back to the garage to hear what they have to say about it, but what's your take on it?

Have any of you heard about anything similar?

If it is a cable, how much work is it to swap/patch one?
A regular cable doesn't cost much... But the work can quickly become expensive, especially with diagnostics.
Ahielia is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:36 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.