Car which burns ECUs and stepper motors - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 29-07-17, 07:52 AM   #1
Junior Member
 
Join Date: Jul 2017
Posts: 1
Default Car which burns ECUs and stepper motors

Hi,

I got strange problem in my 406, 1.8cc (lfy) and now in sort of out of solution situation

All started with poor idling (with misfire and lack of power occasionally). Scanning resulted with below and even after doing through cleaning/checking of throttle body, steeper motor, TPS, MAP, MAF etc

Engine ECU
Permanent fault: Idle actuator


Then I changed the stepper motor and it only lasted for few days. Same problems came with same error code.

Sent the car to dealer. They said that wiring is OK and problem with ECU which send wrong singles to steeper so it get burn at end. Make sense, so I ordered used ECU with new stepper but unfortunately result was the same. It ran only few miles without problems and gave the same error code.

It is very unlikely that my new ECU also having same problem (sending wrong singles to stepper). What could happened is some other part in vehicle damaging the ECU? I did read about famous coil pack problem in 306 with Sagem SL96 ECUs.

Mine also have Sagem but SL96-3 version. I'm wondering (have experience) exactly which SL96 is having coil pack problem. ? (As I red, it is related to SL96-1 and SL96-9). I want to make sure the problem before going to change coil pack , ECU again as it is very costly. Your input is highly appropriate here.

Also, what could be other reasons for damaging the stepper motors/ECUs ? It is very strange and I'm stuck here with this goest car
Any comments/feedback are highly appreciate.
peugeotSL is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-08-17, 01:10 PM   #2
Senior Member
 
Join Date: Jun 2013
Posts: 117
Default

I have the same car, very seldom fails, but when it do it is very difficult to diagnose.
I think the key word is (coil pack), try a new one.
wish you luck.
lovepeugeot is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:54 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.