Air Bag light - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 18-07-19, 02:42 AM   #1
Member
 
Join Date: Oct 2018
Location: New Zealand
Posts: 34
Default Air Bag light

So Iíve got this beater 406 Estate 2.1 which is still going strong but seen better days and the air bag light has started coming on. Iím suspecting itís a wiring issue rather than an actual fault with the air bag because the water contamination warning light was doing the same thing and then it stopped misbehaving. (Yes, I did check the fuel filter the first time but it was fine so I ignored it.) And the fuel and temperature gauges are a bit erratic now and again and give misleading readings.

Hereís the scenario:
- AB light comes on in lamp test mode when turning key to ON
- AB light goes off after engine start and stays off for awhile
- AB light starts flashing regularly then stays on
- After stopping engine for a minute or so the routine starts over again

Anyone seen this and solved it?

Also, the air bags are supposed to be replaced after 10 years, has anyone ever done this? I would imagine with the certification etc. the cost would make the car a write off.

Hermano
Hermano is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 18-07-19, 11:37 AM   #2
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,554
Default

Quote:
Originally Posted by Hermano View Post
Also, the air bags are supposed to be replaced after 10 years, has anyone ever done this? I would imagine with the certification etc. the cost would make the car a write off.

Hermano
I think that's just manufacturer boilerplate to excuse them from any liability for failures.

Most manufacturers consider the life of a car to be ten years, but many components outlast that time.

As for your airbag issue, get a Planet diagnostic to find which one is playing up, then disconnect and re-solder the wires.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 18-07-19, 07:06 PM   #3
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,303
Default

I would check all the earths in the area as a first check
__________________
DS5 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is online now   Reply With Quote Quick reply to this message
 
Old 20-07-19, 03:23 PM   #4
Senior Member
 
Join Date: Jul 2015
Posts: 651
Default

Also check the battery & alternator charging rate.

The airbag system has a protection built in for under & over voltage conditions, its odd the system is happy to pass the self test at start up & only starts flashing after a while of driving.
__________________
308 Allure 1.2 Puretech 130 hatch panoramic roof
Mr Lee is online now   Reply With Quote Quick reply to this message
Old 20-07-19, 05:03 PM   #5
Senior Member
 
Old Pug's Avatar
 
Join Date: Apr 2014
Location: Berkshire
Posts: 859
Default

Favorite fault on old Pugs is the wiring under the front seats that go to the seat belt pre tensioners. While your there have a look under the carpet in the driver`s (RHD) foot well to see if the wiring loom and multi plugs have been contaminated with water.
Old Pug is offline   Reply With Quote Quick reply to this message
Old 20-07-19, 05:49 PM   #6
Moderator
 
trem1's Avatar
 
Join Date: Jan 2010
Location: south shields,tyneside
Posts: 4,986
Default

Quote:
Originally Posted by Old Pug View Post
Favorite fault on old Pugs is the wiring under the front seats that go to the seat belt pre tensioners. While your there have a look under the carpet in the driver`s (RHD) foot well to see if the wiring loom and multi plugs have been contaminated with water.
Agreed

Sent from my K013 using Tapatalk
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 Iron Grey 136bhp 2.0 hdi SE .........Written off
2006 Icelandic Grey 136bhp 2.0HDI SE......Written off
2006 Silver 136bhp 2.0hdi SE......Current car
Join us on FB "Peugeot 407 uk"
trem1 is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:03 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.