AC/Fan foul smell - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 406
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-08-15, 10:26 PM   #1
Inactive User
 
Join Date: Aug 2015
Location: Cranleigh, Surrey, UK
Posts: 27
Default AC/Fan foul smell

Hello all

I've been looking online for a few hours but can't seem to find anything for my symptoms, in fact mine are the complete opposite of other people's experiences. I've got a 2002 406 HDi 90.

When I have the fan (without AC) on cold or hot, I get a very foul mildew/mould/damp smell through the system, however if I turn the AC on, the smell completely goes away. Very odd I know as everything else I've read is the other way round (smell when AC on sounds common). I want to be able to have the fan on without the AC at times for fuel economy but as it is I need to keep the AC on constantly to stop the smell, I'm also slightly concerned about legionnaires disease as I've heard this is a possibility with things like this.

The AC works fine, and the smell has been gradually getting worse over the last month to 6 weeks or so (using the AC most days for at least half an hour). The worse the smell is getting, the less effective the AC is becoming it seems.

From doing some digging online I gather most cars have a condensation drain line which normally drains straight onto the road, and on some cars it is on the passenger side behind the firewall, I've heard of this pipe becoming blocked which could cause a condensation build up, but I can't find where the pipe is on my 406, I've checked the Haynes manual but it doesn't go into much detail on the AC and doesn't mention the location of the drain pipe.

Can anyone advise where the problem could be or what I can check?

Any advice would be very much appreciated.
fitzy89 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-08-15, 01:26 AM   #2
Inactive User
 
14.5:1's Avatar
 
Join Date: Dec 2014
Location: Cavan Ireland home of potholes you can bury a car in.
Posts: 165
Default

Unusual did you change your pollen filter? Could be that simple, or you might have to pull your dash, i'd start with whats easy.
14.5:1 is offline   Reply With Quote Quick reply to this message
Old 03-08-15, 01:31 AM   #3
Senior Member
 
Join Date: May 2015
Posts: 185
Default

Is the floor carpet wet at all?
Phil_dodd is offline   Reply With Quote Quick reply to this message
 
Old 03-08-15, 12:38 PM   #4
Inactive User
 
Join Date: Aug 2015
Location: Cranleigh, Surrey, UK
Posts: 27
Default

Hi again thanks for the responses, no the carpet doesn't appear wet at all, I had a good clear out and vacuumed out the car yesterday and no sign of damp at all.

I haven't checked the pollen filter yet but will have a look later today, does the cover just unclip near the windscreen wiper or is it somewhere else?

Just seems very odd to me to be happening like this. I only got the car in March this year and everything else has been fine and it didn't smell bad when I got it, it's just been getting progressively worse since I've been using the AC in the warmer weather. Just really odd that I can't smell it when the AC is on but reeks to the high heavens with the fan on it's own. Is there anywhere that water or condensation could build up in the system at all?
fitzy89 is offline   Reply With Quote Quick reply to this message
Old 03-08-15, 03:54 PM   #5
Inactive User
 
Join Date: Aug 2015
Location: Cranleigh, Surrey, UK
Posts: 27
Default

Hi again.

I've had a look at the pollen filter, it needs replacing to say the least, had about half a tree's worth of leaves in there and a mouse nest, I've cleaned it all out for now, given the filter a good bash to get the little bits out but I don't think it's the cause of the smell in this case as it was completely dry and didn't appear to smell at all, makes me think something else could be causing it. I'm not sure how fresh the mouse nest was, guess it's possible one of the little buggers could have gone further down and died in there but I think the smell would be a lot more putrid if that was the case too.

So even though the filter is dirty, as it doesn't smell at all I think I can rule that out. Would the next step be to pull out the glove box and blower and check everything in that area?

I'd still like to check the pipe for the air con condensation drain but I'm still not too sure where that is located. As this is my first diesel car I'm a little unfamiliar with what's under the bonnet, I know how a diesel engine roughly works but not 100% sure what all the parts are on it. There's a pipe coming down from this with nothing on the other end of it, could that be it? Nothing comes out when loosening the collar on the top end of the pipe:

fitzy89 is offline   Reply With Quote Quick reply to this message
Old 03-08-15, 05:47 PM   #6
Senior Member
 
erick-r's Avatar
 
Join Date: Jan 2015
Location: Mexico City
Posts: 361
Default

Don't clean the pollen filter, just throw it away and replace with a new one. Although you see it 'clean' surely remains there a lot of spores or similar stuffs that provoke the smell.

I replaced my pollen filter few weeks ago and it was very notable how the bad odour almost disappeared. Similar to your case, when I turned on the fan without AC, that characteristic smell appeared.

There are also products to clean and deodorize AC system, because after have a mouse nest there, who knows what kind of micro bugs could your system hosting now..

Hope it helps, erick
erick-r is offline   Reply With Quote Quick reply to this message
Old 04-08-15, 12:50 AM   #7
Inactive User
 
Join Date: Aug 2015
Location: Cranleigh, Surrey, UK
Posts: 27
Default

Ok thanks for the info. I'll replace the filter anyway but was just a quick clean out until I get the chance to replace it.

Ignore that photo I posted, I've since learnt from here that it's the fuel filter

I'll also check the recirculation flap when I get a moment and make sure that's operating as it should, I did read another thread about a 406 smelling musty which turned out to be the flap getting stuck closed so not allowing fresh air into the car.

Thanks for all the helpful advice guys, appreciate it, I'll contribute to anything I can in the forums but as this is my first Peugeot I don't know if I'll be able to help much
fitzy89 is offline   Reply With Quote Quick reply to this message
Old 16-10-15, 09:41 PM   #8
Inactive User
 
Join Date: Aug 2015
Location: Cranleigh, Surrey, UK
Posts: 27
Default

Evening all. I'm back. After the lasts posts a while ago I did replace the pollen filter which resolved the issue for about a week and then the smell suddenly came back again. It really is so odd that it only happens with just the fan on (no AC). Ever since then the smell seems to come and go with no explanation and I can't see any indication of the cause. I've checked the recirculation flap which is operating fine. I've run a can of 'AC Bomb' as the motor factors call it (press the top of can down, leave it emptying in the vehicle with fan on for 15 mins or whatever it said on the can) to clean everything out but that didn't seem to make a lot of difference, again it's just off and on some days it'll smell bad others it won't. I can't seem to link it to wet weather either as it has happened on dry days as well. Really confusing indeed.
fitzy89 is offline   Reply With Quote Quick reply to this message
Old 16-10-15, 09:52 PM   #9
Senior Member
 
Join Date: May 2015
Location: Cardigan
Posts: 174
Default

I suspect a dead rodent decomposing in the ventilation system and the smell increasing with temperature maybe , not 100% sure but doesn't the A/c just recirculate the interior (smelly) air ? hmmmm!
roybach is offline   Reply With Quote Quick reply to this message
Old 16-10-15, 10:02 PM   #10
Inactive User
 
Join Date: Aug 2015
Location: Cranleigh, Surrey, UK
Posts: 27
Default

I suspected a rodent initially but the odd thing is when AC is on, the smell completely disappears (which is the complete opposite of what I would expect). It's just really strange. I think I need to strip the dash out and see what's going on behind there because it just doesn't make sense with anything I've read about so far
fitzy89 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 10:07 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.