Help 407 cranshaft sensor - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 4007
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 30-08-17, 01:20 PM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 6
Default Help 407 cranshaft sensor

Hi new to this so 'be gentle'-changed cranshaft sensor and it wont start , replaced old one and wont start ?
I need this puppy back on the road TODAY !!!
IDEAS PLEASE
Ali voy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 30-08-17, 02:46 PM   #2
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,089
Default

Hi...why did you change the 1st crankshaft sensor...more information will help
noddy-hol is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 03:45 PM   #3
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,897
Default

Need more info was it starting before you changed it ?
did you disconnect the battery before doing it ?

Is there a key warning on dash ?
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
 
Old 30-08-17, 03:46 PM   #4
Junior Member
 
Join Date: Aug 2017
Posts: 6
Default

Cut out last night -AA did diagnostic which said crankshaft sensor fail, was dripping in dirty oil so he cleaned it and i drove home 40ml fine -he did say worth changing incase intermitent fault -so i did and now it wont restart
Ali voy is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 03:49 PM   #5
Junior Member
 
Join Date: Aug 2017
Posts: 6
Default

Didnt disconect battery ?
Is that a prob ?
Engine mgnt light now on !!!
Ali voy is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 05:01 PM   #6
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,391
Default

Did you get the correct sensor, if it was the wrong one it may have logged a fault which is stopping it starting
__________________
DS5 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 05:35 PM   #7
Junior Member
 
Join Date: Aug 2017
Posts: 6
Default

Local parts shop gave me part according to reg so im presuming so
Diagnostics from a mate not showing any codes
Ali voy is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 05:56 PM   #8
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,089
Default

HI...does it crank over at a fair speed..or is it just dead..?
noddy-hol is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 07:22 PM   #9
Junior Member
 
Join Date: Aug 2017
Posts: 6
Default

Yeah cranking over just not fireing
Ali voy is offline   Reply With Quote Quick reply to this message
Old 30-08-17, 07:29 PM   #10
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,897
Default

2 things

1 sensor may not have been the fault WIRING is far more likely and you have now broken the circuit
2 diagnostics needs LIVE DATA codes dont help here live data and lots of it

In live data you need to see an engine speed signal if it is not showing anything while cranking or it is less than 250 rpm engine wont fire

Not disconnecting battery is fine it is more likely to cause issues if you DO disconnect due to 3 minute rule etc
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:01 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.