Sat Nav Miles Off - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 308 > 308 (2014+)
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 29-07-19, 01:41 PM   #1
Junior Member
 
Join Date: Apr 2019
Location: Glasgow
Posts: 3
Default Sat Nav Miles Off

I've had a 308SW 1.6 Diesel (15) for a few months now and I like the car, but the sat nav is showing me miles away from where I am. It was intermittent at first but now it's all the time. Upgrading the maps didn't help and although I don't really need it much it would be nice to have it working properly. Any suggestions would be appreciated.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dingy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-07-19, 03:46 PM   #2
Senior Member
 
Paul-R's Avatar
 
Join Date: Mar 2018
Location: Wirral, UK
Posts: 833
Default

This could be expensive. My C5 did somewhat of the same thing (the satnav was also by Magnetti Marelli) and showed me driving through the Irish Sea. The dealer ending up replacing the e-Myway head end unit (radio/satnav, etc) - under warranty fortunately. I believe that otherwise it would have cost the thick end of 1000.

The 308 has also had the SMEG+ unit replaced but for a different reason. Again under warranty. It does seem that there might be a question about MM's reliability. Possibly why PSA have moved away from them?
__________________
2015 1.6 Blue HDi 120 Peugeot 308 Active SW
Paul-R is online now   Reply With Quote Quick reply to this message
Old 29-07-19, 06:09 PM   #3
Senior Member
 
ShereKhan's Avatar
 
Join Date: Oct 2015
Location: Bristol/Manchester
Posts: 539
Default

Quote:
Originally Posted by Dingy View Post
I've had a 308SW 1.6 Diesel (15) for a few months now and I like the car, but the sat nav is showing me miles away from where I am. It was intermittent at first but now it's all the time. Upgrading the maps didn't help and although I don't really need it much it would be nice to have it working properly. Any suggestions would be appreciated.
Have you tried to do a soft reboot whilst the system is on?
Have you checked the connections are ok at the back? Aerial maybe? Does the DAB work ok?
__________________
2015 Peugeot 308 GT Auto 5DR
2010 BMW F10 520d SE
ShereKhan is offline   Reply With Quote Quick reply to this message
 
Old 29-07-19, 10:46 PM   #4
Senior Member
 
Join Date: Feb 2006
Location: Surrey
Posts: 1,972
Default

Mine did that once, showing me about 5 miles from where I knew I was. I had stopped for a break and when I started up again it was like that. Next morning it was back to normal. Never done it since.

Mind you, it's no worse than sitting on a ferry, about 1 hour south of Newhaven and getting a message on the mobile saying "Welcome to Iceland".
__________________
Brian,
2015 308 SW II Allure 1.6 Blue HDi 120.
Brilec is offline   Reply With Quote Quick reply to this message
Old 30-07-19, 11:20 AM   #5
Member
 
Join Date: Sep 2015
Posts: 43
Default

Quote:
Originally Posted by Dingy View Post
I've had a 308SW 1.6 Diesel (15) for a few months now and I like the car, but the sat nav is showing me miles away from where I am. It was intermittent at first but now it's all the time. Upgrading the maps didn't help and although I don't really need it much it would be nice to have it working properly. Any suggestions would be appreciated.
Check this thread, might be your gps receiver is failing.

I replaced mine with a dirt cheap one, easy fix and worth a shot..

https://www.peugeotforums.com/forums...-issue-334348/
Blabladiebla is offline   Reply With Quote Quick reply to this message
Old 30-07-19, 12:25 PM   #6
Senior Member
 
mooi1uk's Avatar
 
Join Date: Jan 2013
Location: Cornwall UK
Posts: 1,650
Default

I have read on these forums somewhere in the past that this can also be caused by a faulty ABS sensor on one of the front wheels. I know it sounds unlikely but apparently the satnav GPS location is determined by an ABS sensor on the front wheels.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1.6THP GTLine EAT6 Leather+Grip+ACC+O&G+Smart Boot

Last edited by mooi1uk; 30-07-19 at 01:01 PM.
mooi1uk is online now   Reply With Quote Quick reply to this message
Old 30-07-19, 04:04 PM   #7
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,303
Default

The wheel speed is only used by the satnav when it has no lock on the GPS to guestimate the vehicles position based on distance travelled from last lock.
mooi1uk likes this.
__________________
DS5 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is online now   Reply With Quote Quick reply to this message
Old 31-07-19, 12:39 PM   #8
Junior Member
 
Join Date: Apr 2019
Location: Glasgow
Posts: 3
Default

Quote:
Originally Posted by Blabladiebla View Post
Check this thread, might be your gps receiver is failing.

I replaced mine with a dirt cheap one, easy fix and worth a shot..

https://www.peugeotforums.com/forums...-issue-334348/
I seem to have the same problem as you had so I'm going to try the same solution. I'll let you know how I get on.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dingy is offline   Reply With Quote Quick reply to this message
Old 31-07-19, 07:39 PM   #9
Member
 
Join Date: Sep 2015
Posts: 43
Default

Quote:
Originally Posted by Dingy View Post
I seem to have the same problem as you had so I'm going to try the same solution. I'll let you know how I get on.
well, for what it's worth, I never took the thing out again or stuck the cables down with cable ties..
Just let it sit there the same way it sat when I first magnetically stuck it onto the roof.
It works and I'm very happy I managed to fix it with a 8,- part..

Always worth a shot, with amazon nowadays if it proves not to be the issue, you can always return it for a full refund..

Hope yours will work out too...
Blabladiebla is offline   Reply With Quote Quick reply to this message
Old 01-08-19, 10:38 PM   #10
Junior Member
 
Join Date: Jul 2019
Location: Norway
Posts: 1
Default

Had the same problem with my Citroen DS3. Dealer replaced the GPS antenna and everything was fine
notrix is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:48 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.