Sluggish with no boost - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 308 > 308 (2007-2014)
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-12-18, 10:37 AM   #1
Member
 
Join Date: Apr 2017
Location: Glasgow City Centre
Posts: 33
Default

Hi all, apologies if this has been asked/mentioned before but I couldn't find any with the same issue but there was a couple close to it...

I have a 2009 308 1.6hdi 5 Dr hatchback with 136k on the clock.

Over the last few months it has started to give issues. It started with one issue and that is when started, won't rev over 3k, sounds like slight miss fire when trying too. Aka irratic revs at 3k. But when given a few minutes to run and some revs it does eventually.

When going, it still feels like it isn't boosting at all. Now it is coming up with anti pollution warning with the engine management light staying on. It does sometimes go out and the car picks up a little but still slow. Hard when joining motorways.

I have had it into a local garage a couple of times but feel like they don't know how to fix it.

I was advised and fixed the following:
Fuel filter, egr valve, glow plugs, glow plugs relay, recommended another service, replaced oil filter, air filter, o2 sensor.

About a year ago the turbo was replaced and along with flywheel and clutch.

I am now getting to my wit's end and need some recommendations...
Can anyone advise if they have had this issue or are having the issue?

Any help would be appreciated.
RustyChillie is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-12-18, 05:50 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

There is no 02 sensor ! could be a vacuum issue it could be a DPF issue but depends on WHAT flavour your engine is as there are many versions of 1.6 HDI
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 03-12-18, 06:05 PM   #3
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

One thing you could do is get the car over to Reliable. He has the skills, equipment and knowledge to sort it out.

If not, you need to find someone with Diagbox/PP2000 who can do a full code and live reading scan and dig out historic errors. Find someone on the MAP
WillNZ is offline   Reply With Quote Quick reply to this message
 
Old 03-12-18, 06:22 PM   #4
Member
 
Join Date: Apr 2017
Location: Glasgow City Centre
Posts: 33
Default

Quote:
Originally Posted by reliable406 View Post
There is no 02 sensor ! could be a vacuum issue it could be a DPF issue but depends on WHAT flavour your engine is as there are many versions of 1.6 HDI
Sorry, meant maf....lol
Dpf fluid was replaced and filter was purged a few months ago.
Is there a best way to check the vacuum on the engine? Any hints/tips?

What can you recommend regards to flavour of engine?

Last edited by RustyChillie; 03-12-18 at 06:32 PM.
RustyChillie is offline   Reply With Quote Quick reply to this message
Old 03-12-18, 06:26 PM   #5
Member
 
Join Date: Apr 2017
Location: Glasgow City Centre
Posts: 33
Default

Quote:
Originally Posted by WillNZ View Post
One thing you could do is get the car over to Reliable. He has the skills, equipment and knowledge to sort it out.

If not, you need to find someone with Diagbox/PP2000 who can do a full code and live reading scan and dig out historic errors. Find someone on the MAP
Yeah, checked that, but unfortunately there is no-one near my location lol.

Yeah, might have to purchase one. Seen some kits online. I.e. eBay lol. The local garage I go to, which usually 99 times out 100 are spot on, are unable to resolve the issue...
RustyChillie is offline   Reply With Quote Quick reply to this message
Old 03-12-18, 07:02 PM   #6
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

Last i checked im not far from glasgow has it moved
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 03-12-18, 07:09 PM   #7
Member
 
Join Date: Apr 2017
Location: Glasgow City Centre
Posts: 33
Default

Quote:
Originally Posted by reliable406 View Post
Last i checked im not far from glasgow has it moved <img src="https://www.peugeotforums.com/forums/images/smilies/smile.gif" border="0" alt="" title="Smile" class="inlineimg" />
Haha apologies, scanned through the list and didn't think any was nearby haha.

Ever come across anything like this?
RustyChillie is offline   Reply With Quote Quick reply to this message
Old 03-12-18, 07:21 PM   #8
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,904
Default

If you are willing to drive over i can certainly have a look
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 03-12-18, 07:33 PM   #9
Member
 
Join Date: Apr 2017
Location: Glasgow City Centre
Posts: 33
Default

Quote:
Originally Posted by reliable406 View Post
If you are willing to drive over i can certainly have a look
Thanks. Sent an IM. Cheers
RustyChillie is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:15 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.