Radiator fan on full speed seconds after ignition - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 308 > 308 (2007-2014)
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By iantett

Reply
 
LinkBack Thread Tools Display Modes
Old 26-01-18, 03:24 PM   #1
Junior Member
 
iantett's Avatar
 
Join Date: Jan 2018
Location: Aberdeen, Scotland
Posts: 6
Angry Radiator fan on full speed seconds after ignition

Hi folks, seriously needing some help. A couple of seconds after starting the car, the radiator fan kicks in full speed and will run until the engine is switched off. The thermostat housing has been replaced with no luck, any advice would be greatly appreciated, no lights or messages on dashboard, diag machine comes up with no errors and local Peugeot specialists want £100 +VAT just to look at it. It's a 2011 Peugeot 1.6 VTI Active, 52,000 miles, petrol
iantett is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-01-18, 05:38 PM   #2
Senior Member
 
Join Date: Jul 2017
Location: Glenrothes
Posts: 718
Default

could be a stuck fan relay,not sure if its located in behind the front grill like on most peugeots or not on the 308...

just checked servicebox and seems it is
item no 6 on this diagram

screen-shot-01-26-18-06-34-.jpg


heres a couple of wiring diagrams in case you need them

screen-shot-01-26-18-06-28-.jpg


screen-shot-01-26-18-06-30-.jpg
__________________
Peugeot 307xsi 2.0hdi 110bhp 2004.
terry57 is offline   Reply With Quote Quick reply to this message
Old 27-01-18, 10:20 AM   #3
Junior Member
 
iantett's Avatar
 
Join Date: Jan 2018
Location: Aberdeen, Scotland
Posts: 6
Default

Thank you for that, ill put it to the mechanic and see if that helps
__________________
2011 Peugeot 308 1.6 VTI Active
iantett is offline   Reply With Quote Quick reply to this message
 
Old 27-01-18, 10:47 AM   #4
Senior Member
 
Join Date: Nov 2017
Posts: 131
Default

Is the oil dipstick and oil filler cap on properly?

On the end of the cylinder head can you see the coolant temp sensor , I cannot remember if itís on the thermostat housing or not ?? Have a look at that see if thereís any water or corrosion on the twin wire sensor .
mechcanico is offline   Reply With Quote Quick reply to this message
Old 27-01-18, 10:51 AM   #5
Senior Member
 
Join Date: Feb 2006
Location: Surrey
Posts: 2,133
Default

Is there just the one coolant temp sensor? Or is there one for the gauge/ECU and one for the fan?
__________________
Brian,
2015 308 SW II Allure 1.6 Blue HDi 120.
Brilec is online now   Reply With Quote Quick reply to this message
Old 27-01-18, 11:28 AM   #6
Senior Member
 
Join Date: Jul 2017
Location: Glenrothes
Posts: 718
Default

Quote:
Originally Posted by Brilec View Post
Is there just the one coolant temp sensor? Or is there one for the gauge/ECU and one for the fan?
would need his VIN number to check that
__________________
Peugeot 307xsi 2.0hdi 110bhp 2004.
terry57 is offline   Reply With Quote Quick reply to this message
Old 29-01-18, 09:45 AM   #7
Junior Member
 
iantett's Avatar
 
Join Date: Jan 2018
Location: Aberdeen, Scotland
Posts: 6
Default

Hi again folks, thermostat housing has 2 temp sensors and fan relays are fine, oil filler cap and dipstick are secure. Have also just found out that the fan behaves if the car get used again while the engine is still warm, done this at the weekend, parked the car, done some shopping (about 1.5 hrs) went back to the car and the fan didn't kick in as before.
__________________
2011 Peugeot 308 1.6 VTI Active
iantett is offline   Reply With Quote Quick reply to this message
Old 12-02-18, 11:55 AM   #8
Junior Member
 
iantett's Avatar
 
Join Date: Jan 2018
Location: Aberdeen, Scotland
Posts: 6
Default

Final update folks, problem turned out to be a faulty resistor within the fan relay, it just goes to show, I should have taken it to someone who knows Peugeots
terry57 likes this.
__________________
2011 Peugeot 308 1.6 VTI Active
iantett is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:48 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.