Peugeot 308 1.6 anti pollution headaches - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 308 > 308 (2007-2014)
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 24-12-15, 04:57 PM   #1
Inactive User
 
Join Date: Dec 2015
Location: Pretoria , South Africa
Posts: 18
Default Peugeot 308 1.6 anti pollution headaches

Hi I have the 88kw Mini powered version , anti pollution fault comes up after driving on a highway trip. I have changed the plugs , the coil packs , then found out that the o2 sensor plug wasn't making contact fixed that then a new code reappears on my obd2 car scanner doctor P1339, says o2 sensor went in open loop during deceleration at 3250 rpm and water temp sensor read 102 deg celcius at that freeze frame , the car goes into limp mode musfiring then cutting out the electronic function readings on the obc. Ie the litres per 100 stops working and the fuel range goes up. I stop the car for a while then start it again then drives fine but with the eml apf light still showing, the next day the fan comes on now and then then the eml switches off and drives fine until the next highway trip the apf will come back again but never goes into apf around town. I noticed that after I clear the fault code P1339, when driving around in out hot summers the electric fan never comes on but temp gauge stays on half. ( fan only comes on when the eml light comes on )
The engine does have a rough idle ( car revs cleanly to 6500rpm without s misfire ) but the mechanic told me this is due to cylinders number 2 and 4 which showed 1000 and 800psi ( 1 and 3 showed 1300) on the compression test and told me the previous owners -mechanics never seated the exhaust valves correctly. I bought the car just after they had done the head over and head gasket as the car overheated with them due to a faulty radiator which was also replaced . Should I go to Peugeot to find out if they can pick up a faulty sensor or injector or should I rather get my compression sorted first by reseating the valves? Does my car run too hot or can it be a blocked cat convertor( the 02 sensors read rich voltages and I the exhaust does smell like paint thinners on idle ) any suggestions? I am from South Africa
30head8s is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:55 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.