no acceleration - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 308 > 308 (2007-2014)
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 31-01-13, 08:10 AM   #1
Inactive User
 
Join Date: Dec 2012
Posts: 6
Default no acceleration

I have a 308 1.6vti sport 08 plate and have just started having problems with acceleration.
It seems ok in first and second, not too bad in third, terrible in fourth and fifth. I struggle to get past 50mph and overtaking is a thing of the past and it just hasn't got the power.
Any help would be greatly appreciated!
stoss is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 30-08-13, 09:10 AM   #2
Inactive User
 
Join Date: Aug 2013
Posts: 4
Default Power loss .

Hi , I know you post ages ago on this subject but I am having the exact same problem / same car . Do you know what was done changed thanks a lot as I am desprate . Cheers
Fires05 is offline   Reply With Quote Quick reply to this message
Old 31-08-13, 09:19 AM   #3
Inactive User
 
Join Date: Dec 2012
Posts: 6
Default power loss

I had a diagnostic done at a local 'run of the mill' garage and they replaced the coil pack and the spark plugs as they thought this would fix the problem. It didn't. The problem still persisted so I bit the bullet and took it into my local peugeot garage. They did their own diagnostic and came to the conclusion that the catalytic converter had collapsed internally which was what was causing the problem. They also had to download an update or something as I remember to sort out the problem too. This worked and the car was back to normal. Possibly even better. I had to pay something like 800 though for the work which was shocking but cats aren't cheap. I would recommend you do the same as me. Take it into a peugeot garage and get them to check it out as any other garage might misdiagnose the problem and you'll end up paying more in the end. No one likes forking out that kind of money and I hope your fault isn't as costly as mine. Please get in touch if you have any more questions or post again if you get the problem resolved. Good luck!
stoss is offline   Reply With Quote Quick reply to this message
 
Old 31-08-13, 10:06 AM   #4
chopper1192
Guest
 
Posts: n/a
Default

Considering they failed to fix the fault, will the first garage be refunding you?
  Reply With Quote Quick reply to this message
Old 01-09-13, 07:21 AM   #5
Inactive User
 
Join Date: Aug 2013
Posts: 4
Default Update

Hi . Just a quick update for you .
Last year 2-3000 miles ago had a service at a peugeot garage . This was a 40k service which should include an air filter and spark plugs . Thought I would just check them yesterday and found that they have never been changed .
Maybe this was an error me paying for a full service and being charged and them failing to replace parts wink wink .
Anyway after trying new ones it ran worse and depullution light came on . Well pulled off cover again and checked coil packs and one was black inside and others silver . Gave it a clean , all fixed . Back to full power .
Just needs the light turning off . Fan starting tuning all the time but fixed when coil was cleaned .
Thanks for any replys members . And good luck we all need it .
Fires05
Fires05 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:49 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.