Depollution system faulty/power loss - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 308 > 308 (2007-2014)
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 15-05-13, 03:11 AM   #1
Inactive User
 
Join Date: Mar 2013
Posts: 3
Default Depollution system faulty/power loss

Hi. I have a 2008 308 1.6 thp (petrol). Recently had the depollution system fault warning and check engine light come on. Had the fault codes read, P2262 and P0299. Dealer advised changing the solenoid valve and pipe on the turbo. Had this done at a cost of 270 but the same day I picked the car up the same thing happened with the warnings on the dash! Any help out there would be welcomed
sjayhuk is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 15-05-13, 07:34 AM   #2
davidireland
Guest
 
Posts: n/a
Default

Is the engine ecu software up to date? It fixed alot in this engine. Ill look up those codes.

Sent from AutoGuide.com Free App
  Reply With Quote Quick reply to this message
Old 15-05-13, 08:26 AM   #3
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,654
Default

They are turbo fault codes but I'm wondering if the problem is further up the system causing these codes?
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
 
Old 15-05-13, 09:26 AM   #4
Inactive User
 
Join Date: Mar 2013
Posts: 3
Default

ECU software all up to date. Got it booked in at dealers for Tuesday to take a look. Will post on here any news. Thanks
sjayhuk is offline   Reply With Quote Quick reply to this message
Old 22-05-13, 03:12 PM   #5
Inactive User
 
Join Date: Mar 2013
Posts: 3
Default

Problem solved. turns out when the garage changed the solenoid valve they got some oil on the vacuum pipe, which swelled up and blocked completely! New pipe fitted today and all is well.
sjayhuk is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 05:25 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.