Urgent help required - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 28-01-14, 03:40 PM   #1
Inactive User
 
Join Date: Dec 2013
Posts: 27
Default Urgent help required

was driving along today all was going well went down a farm track through a puddle about 7 or 8" deep half hour later anti pollution fault comes up get limp mode with no light on and its bellowing smoke out the back of it.

Any ideas?????????????
dervdoctor is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 28-01-14, 04:15 PM   #2
Inactive User
 
Join Date: Nov 2013
Posts: 49
Default

I think it's just a coincidence, driving through a puddle.

Take it for a motorway run, 3000rpm for 20 minutes should force a regen of the DPF, see if that sorts it.

I think the only way a puddle would cause issues is if you have a hole in your DPF and it's filled up with water.
Grizwald is offline   Reply With Quote Quick reply to this message
Old 28-01-14, 04:15 PM   #3
Moderator
 
trem1's Avatar
 
Join Date: Jan 2010
Location: south shields,tyneside
Posts: 4,997
Default

what colours the smoke ????
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 Iron Grey 136bhp 2.0 hdi SE .........Written off
2006 Icelandic Grey 136bhp 2.0HDI SE......Written off
2006 Silver 136bhp 2.0hdi SE......Current car
Join us on FB "Peugeot 407 uk"
trem1 is online now   Reply With Quote Quick reply to this message
 
Old 28-01-14, 05:06 PM   #4
Inactive User
 
Join Date: Dec 2013
Posts: 27
Default

smokes blueish was black was sat on drive trying to clear it but just gets hot
dervdoctor is offline   Reply With Quote Quick reply to this message
Old 28-01-14, 07:45 PM   #5
Inactive User
 
Join Date: May 2007
Location: Lancaster , lancs
Posts: 134
Default

Quote:
Originally Posted by dervdoctor View Post
was driving along today all was going well went down a farm track through a puddle about 7 or 8" deep half hour later anti pollution fault comes up get limp mode with no light on and its bellowing smoke out the back of it.

Any ideas?????????????
Is it possible the electrovalve(s) have sucked some water in thought the foam covered inlet and have pulled water into the vac system ?

This could have affected the turbo control and put it into limp ?

I ask this because I sprayed wd40 into one when investigating faults and it did the same until the oil had cleared the system.

Just thought, it did the limp, but not to pollution fault

Last edited by Gary C; 28-01-14 at 07:48 PM.
Gary C is offline   Reply With Quote Quick reply to this message
Old 28-01-14, 09:26 PM   #6
Inactive User
 
Join Date: Dec 2013
Posts: 27
Default

Quote:
Originally Posted by Gary C View Post
Is it possible the electrovalve(s) have sucked some water in thought the foam covered inlet and have pulled water into the vac system ?

This could have affected the turbo control and put it into limp ?

I ask this because I sprayed wd40 into one when investigating faults and it did the same until the oil had cleared the system.

Just thought, it did the limp, but not to pollution fault
if i pull all the hoses off would it blow the water out
dervdoctor is offline   Reply With Quote Quick reply to this message
Old 28-01-14, 09:35 PM   #7
Inactive User
 
Join Date: Dec 2013
Posts: 27
Default

also i have a theory with the dpf i think the cable that connects the sensor in the dpf gets wet and shorts and brings up anti pollution fault only ever happens when its raining or when i go tracking
dervdoctor is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 06:02 PM   #8
Inactive User
 
Join Date: May 2007
Location: Lancaster , lancs
Posts: 134
Default

Quote:
Originally Posted by dervdoctor View Post
if i pull all the hoses off would it blow the water out
The system sucks so it won't blow out, but in theory it should clear itself after a while. Not sure if this is the problem though. You could check if there is any moisture in the pipework.

Would be worth checking for the codes that are causing the limp mode.

Last edited by Gary C; 29-01-14 at 06:05 PM.
Gary C is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 06:11 PM   #9
Inactive User
 
Join Date: Dec 2013
Posts: 27
Default

put a full redex diesel treatment in thrashed it along for a few miles switched it off and on again floored it big cloud of black soot left a dirty black line up the road seems alot better now. fingers crossed its finished and fixed
dervdoctor is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:17 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.