Secondary Air Pump - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-05-17, 06:38 AM   #1
Junior Member
 
Join Date: Apr 2017
Posts: 9
Default Secondary Air Pump

On my 2004 307cc, I have the dreaded AntiPollution Fault coming up (P0410).

I was doing some troubleshooting... I dismantled the Secondary Air Pump to expose the motor, trying to check for voltage and running of the pump.

Despite running the car for quite a while, I saw no voltage being applied to the motor or any running.

The motor continuity seems good, and the fuse was good.

So, I have some questions for the gurus:

When should I expect the motor to run?

Is there any way to turn it on manually for testing... pp2000 maybe?

Is there also a solenoid in the circuit to allow airflow from the pump (when it is running) into the exhaust system?

Any suggestions for testing... what I should be looking for?

TIA
Artie
ArtieUK is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-05-17, 10:03 AM   #2
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,502
Default

You should have an option to test in planet under engine ecu actuator test.

Pump should only run on cold startup (i think coolant temp below around 15C from memory) to clean up emissions from rich cold start mixture
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Old 12-05-17, 03:56 PM   #3
Junior Member
 
Join Date: Apr 2017
Posts: 9
Default

Quote:
Originally Posted by windy1603 View Post
You should have an option to test in planet under engine ecu actuator test.

Pump should only run on cold startup (i think coolant temp below around 15C from memory) to clean up emissions from rich cold start mixture
Thanks for your reply windy :-)

ArtieuK
ArtieUK is offline   Reply With Quote Quick reply to this message
 
Old 12-05-17, 04:18 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,043
Default

I agree pump runs only when starting it does not do much and i doubt this is anything directly to do with you antipollution fault.

There is an EGR valve on the back of your head and this can play up the injectors can also flow badly causing anti pollution to be displayed
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 12-05-17, 06:31 PM   #5
Junior Member
 
Join Date: Apr 2017
Posts: 9
Default

Quote:
Originally Posted by reliable406 View Post
I agree pump runs only when starting it does not do much and i doubt this is anything directly to do with you antipollution fault.

There is an EGR valve on the back of your head and this can play up the injectors can also flow badly causing anti pollution to be displayed
Thanks reliable.... can the EGR valve and injectors be easily tested?

ArtieUK
ArtieUK is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:55 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.