Peugeot 307sw 1.6 16v - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By reliable406

Reply
 
LinkBack Thread Tools Display Modes
Old 02-06-18, 11:22 PM   #1
Junior Member
 
Join Date: Jun 2018
Posts: 2
Default Peugeot 307sw 1.6 16v

Hi, I recently got myself another peugeot which is the 307sw with 1.6 16v under the bonnet. I was happy with the car for the first few weeks until the "Check engine" light came on, I have connected my diagnostic computer and got an error p0341 - Camshaft position sensor issue. I went ahead and got a new replacement sensor, fitted and no change so I went and got a lend of 100% good sensor from a mates car and still no change... At this point I didnt know what to do so went onto Autodata and did a bit of research on the harness and started to check it. I noticed there were cables added to extend the cable that is going to the sensor so got rid of them and did a straight cable from the sensor to the ecu but that didnt do any help. Did anyone have a problem similar to mine ?

Last edited by Procidant; 04-06-18 at 12:25 AM.
Procidant is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-06-18, 08:10 AM   #2
Member
 
Join Date: May 2018
Location: South Wales
Posts: 58
Default

Hi, are you sure that's the fault code number you got? P0431 comes up as warm up catalyst efficiency below threshold Bank 2 in my data book.
CpLuAg is offline   Reply With Quote Quick reply to this message
Old 03-06-18, 08:42 AM   #3
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,049
Default

I agree that code is not a cam sensor code but more importantly the NFU engine you have has no cam sensor
madbadandold likes this.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
 
Old 03-06-18, 08:53 AM   #4
Senior Member
 
Join Date: Oct 2015
Location: Cap D'Agde, France
Posts: 251
Default

Are you using Planet or a generic fault reader?
patspiercing is offline   Reply With Quote Quick reply to this message
Old 04-06-18, 12:24 AM   #5
Junior Member
 
Join Date: Jun 2018
Posts: 2
Default

Sorry just a typo its P0341
Procidant is offline   Reply With Quote Quick reply to this message
Old 04-06-18, 03:46 PM   #6
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,049
Default

Regardless of what it is the NFU engine has NO cam sensor what exactly were you changing ?
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 05:35 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.