Fault codes advice please - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 25-05-16, 08:18 AM   #1
Inactive User
 
Join Date: Aug 2010
Posts: 26
Default Fault codes advice please

hi all, i have a 307 estate, 1.6 hdi 110bhp, 55 plate, done just under 80k, i have had the anti pollution fault on and off for about a month now, usually comes on when i go over 2500 rpm in 2nd gear or over 2200rpm in 3rd gear, then goes off over the next few days.

got my car on planet last night and got the following codes

P0238 turbo pressure signal - short circuit to positive or open circuit or value to high.

P0100 Flowmeter signal - Air flow not plausible.


for the first one i think i am going to change the differential pressure sensor, which i beleive is located under the battery tray, any confirmation of that would be great.

as for the flowmeter signal any one have any suggestions as to where to start on this ?

thanks for any help in advance
scojototo2010 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 25-05-16, 08:33 AM   #2
Senior Member
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,825
Default

You may have a bit more luck with some live data, this will give you more of an idea on the air flow.

Check the turbo solenoid wiring, I had a similar problem last week
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 08:50 AM   #3
Inactive User
 
Join Date: Aug 2010
Posts: 26
Default

Quote:
Originally Posted by jimmymarsbar View Post
You may have a bit more luck with some live data, this will give you more of an idea on the air flow.

Check the turbo solenoid wiring, I had a similar problem last week
Thanks for the reply, is the live data done via the planet system as well ? does the car need to be driving about or just with the engine on ?
scojototo2010 is offline   Reply With Quote Quick reply to this message
 
Old 25-05-16, 08:55 AM   #4
Senior Member
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,825
Default

Yes, live data is done through PP - look through the menus for parameter measurement. You can get live data with the car stationary and engine running, but it's probably best to get the car moving and see what it says when everything is under load, and when there's a driving "real time" airflow.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 11:12 AM   #5
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,502
Default

Diffential pressure sensor is not your problem it only measures dpf not boost.

As above check turbo valve and also intercooler hoses for splits etc and that doser valve is working.

Sent from my SM-G900FD using Tapatalk
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 12:14 PM   #6
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,621
Default

Flowmeter is the MAF.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 12:37 PM   #7
Inactive User
 
Join Date: Aug 2010
Posts: 26
Default

Quote:
Originally Posted by Gibbo View Post
Flowmeter is the MAF.
Thanks will that be needing a clean or a new one you think ?
scojototo2010 is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 12:38 PM   #8
Inactive User
 
Join Date: Aug 2010
Posts: 26
Default

Quote:
Originally Posted by windy1603 View Post
Diffential pressure sensor is not your problem it only measures dpf not boost.

As above check turbo valve and also intercooler hoses for splits etc and that doser valve is working.

Sent from my SM-G900FD using Tapatalk
thanks for the reply, will try get a look at all the hose's tonight,
scojototo2010 is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 12:46 PM   #9
Senior Member
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,825
Default

Quote:
Originally Posted by scojototo2010 View Post
Thanks will that be needing a clean or a new one you think ?
You can usually get away with a good clean. Be careful with the gauze and the sensor - they're delicate, so avoid applying pressure with brushes or rags. I use a cleaning solvent aerosol to blast the crap out.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
Old 25-05-16, 12:51 PM   #10
Inactive User
 
Join Date: Aug 2010
Posts: 26
Default

Quote:
Originally Posted by jimmymarsbar View Post
You can usually get away with a good clean. Be careful with the gauze and the sensor - they're delicate, so avoid applying pressure with brushes or rags. I use a cleaning solvent aerosol to blast the crap out.
cheers mate, thanks for the advice
scojototo2010 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:28 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.