Erratic idle and stalling - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 23-07-17, 06:46 PM   #1
Inactive User
 
Join Date: Jul 2017
Posts: 1
Default Erratic idle and stalling

Hi everyone,

A newbie here and not sure if it's in the correct place so sorry if not!


I have a pug 307, 2007 model at 1.4l

I have an erratic idle 95% of the time, it idles between 750-1000 rpm and just jumps up and down you can quite clearly hear the engine slowing down, at night the head lights dim with the idle issue aswell as the heater and internal lights.

Also in a morning or if the car left for a long time like 10 hours at work, if I start the car I can set off and CA hear some sort of misfire/bang in the engine and between 1000-2000 revs if just doesn't want to know sometimes I can keep my foot on the gas pedal and it will shoot past 2000 revs and the car is fine - feels like it's blocked and spluttering.

Sometimes it will stall instead even with my foot pressed down on the gas pedal when it stalls it will start immediately and just drive as normal like the problem doesn't exist.

Also if I start the car a few mins before and rev it a few times then just cut the engine go back inside and have a cuppa or get ready to finish work, I will get back in car 10 mins later and it just drives fine with no signs of stalling.

I have changed the plugs and coil rack - which sorted my anti pollution fault.

I'm stumped now, it's been on computer in the garage so I'm told and nothing shown up. Garage keep saying they will look at it but don't seem interested.


I have looked for an air leak on the pipes and cannot find anything unless I'm not looking properly.

Just to add, the car doesn't stall when driving or show signs of stalling, but I do get a little whiff of petrol sometimes when pulling up to a junction.

The car has done 66000 miles and it's a lovely drive with the idling or stalling issues in a morning!

Sorry for long post I'm just stuck to what to look for now and any advice or to point me in correct direction would be much appreciated. I did think to just get shout of it but I like the drive and the car itself.


Thanks in advance and great forum!
Leetut is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-08-17, 09:29 PM   #2
Junior Member
 
Join Date: Jun 2017
Posts: 4
Default

I've had similar problems. Might be the map sensor maybe? You can find it to the left of the throttle body, try disconnecting it and see if that makes a difference to how the engine runs.
Birdy961 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:02 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.