Engine seems to stall on motorway - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 28-01-14, 08:27 PM   #1
Inactive User
 
Join Date: Jan 2014
Posts: 3
Default Engine seems to stall on motorway

Hi,

Last winter this problem first occurred and a local garage couldn't find a fault. It's been fine since then until now where last week it started happening again.

Randomly, mainly on motorway journeys, of varying lengths, and different times of day, the engine seems to jolt. If I'm quick I can see the rev counter drop right down, but then back up to what it was, say around 20,000.

It can sometimes happen once a journey, other multiple times.

It's a 307cc diesel 2 litre 180 model.

Does anyone have any idea what this could be?

Thanks
Deniscooper is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-01-14, 12:31 AM   #2
Senior Member
 
CMax_307's Avatar
 
Join Date: Aug 2008
Location: Belfast
Posts: 1,045
Default

without any codes could be anything really injectors pump ect engine light on now?
CMax_307 is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 06:24 AM   #3
Inactive User
 
Join Date: Jan 2014
Posts: 3
Default

No error lights are displayed at any point. Guess it needs to go to Peugeot garage to get diagnostic codes.
Deniscooper is offline   Reply With Quote Quick reply to this message
 
Old 29-01-14, 07:23 AM   #4
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,621
Default

No it doesn't:

https://www.peugeotforums.com/forums/...gnostic-28190/
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 07:41 AM   #5
Senior Member
 
CMax_307's Avatar
 
Join Date: Aug 2008
Location: Belfast
Posts: 1,045
Default

as Gibbo points out look at the map and see whos close with planet and they will check your car,

no lights strange as if the car was to lose power it should give you a engine light, I would looking to getting the fuel filter changed in case its blocking the fuel supply just an idea
CMax_307 is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 07:46 AM   #6
Inactive User
 
Join Date: Jan 2014
Posts: 3
Default

Thanks. Messages someone close, I live in birmingham.

It's really strange, it doesn't actually cut out, just the revs drop and it jolts, but it doesn't even last a second, it's so quick, drops then right back up. Did it a few times this morning on motorway.

I can't remember exactly what happened last year, but I remember the revs dropped right down on the motorway and didn't come back up. Had to pull in to hard shoulder, but engine was still going. Turning engine e off and back on fixed it. That only happened twice, otherwise it was just as was now, very very quick.

Strange it only started happening when we had the cold day the other week.
Deniscooper is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 07:52 AM   #7
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,621
Default

I had a similar problem, it was the diesel fuel heater sensor.

A quick diagnostic showed up the fault code for that part. A parameters measurement showed that it was sensing the fuel was -50c.

30 for a new part and all is well.


Another thing it could be is a faulty EGR valve. Again, that will show up with a diagnostic.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 29-01-14, 09:11 AM   #8
pr1vatepiles
Guest
 
Posts: n/a
Default

What sort of fuel are you using? I found in my 307, if i used supermarket fuel, i would get strange things like what you are describing.
  Reply With Quote Quick reply to this message
Old 29-01-14, 02:17 PM   #9
Stubbo
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Deniscooper View Post
I can't remember exactly what happened last year, but I remember the revs dropped right down on the motorway and didn't come back up. Had to pull in to hard shoulder, but engine was still going. Turning engine e off and back on fixed it. That only happened twice, otherwise it was just as was now, very very quick.
I had that about a week ago, engine dropped to tickover and it was almost as if it had lost connection with the pedal

A quick restart and all was good

Mine didn't throw any codes on planet or put the MIL on though so I'm at a loss as to why luckily its only been the once!
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:52 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.