Diagnostics issue - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 30-12-13, 09:51 PM   #1
mac
Inactive User
 
Join Date: Dec 2013
Location: Newcastle Upon Tyne
Posts: 9
Default Diagnostics issue

I bought a cheap 53 plate pug 307 110HDi SE yesterday with 1 or 2 issues.

Its like it has no turbo boost at all, is very flat and down on power.
The car starts first turn of the key, engine sounds sweet, it doesn't smoke or rattle either.

I went to plug a diagnostics machine in this morning and it appears the socket has no power as the machine will not switch on. I double checked the machine was working so I plugged the machine into a different car where it worked fine.

Yesterday when driving the car the EML light was coming on and off, but not all the time.
Today it hasn't come at all when driving but still very flat.

Previous owner informed me that he was told it was some sort of "sensor" which would cost around 70 and that would fix it but he couldn't remember what it was called and he just put up with it. He reckoned it had been like for a year or so.

I had a Citroen Picasso HDI before this and never had any issues with it at all!

Any help would be greatly received.
Thanks,
Mac.
mac is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 30-12-13, 10:18 PM   #2
Inactive User
 
Join Date: Dec 2013
Location: telford
Posts: 24
Default

whats your diagnostic tool?
mark g is offline   Reply With Quote Quick reply to this message
Old 30-12-13, 10:22 PM   #3
mac
Inactive User
 
Join Date: Dec 2013
Location: Newcastle Upon Tyne
Posts: 9
Default

Hey mark,
I used a Autel MaxiDas Diagnostic Machine but also tried a snap-on ethos diagnostic machine and neither would work. They do not even light up as if the diagnostic socket has no power.

Thanks buddy.
mac is offline   Reply With Quote Quick reply to this message
 
Old 30-12-13, 10:41 PM   #4
Inactive User
 
Join Date: Dec 2013
Location: telford
Posts: 24
Default

try to find someone local with planet or diagbox that will do 307 and c5s some versions are queer about 307s apparently, but if you cant i had the exact same fault and it was the differential pressure sensor, it lives behind the battery, google bsi reset or sleep before you remove battery, it could cost if you dont.
mark g is offline   Reply With Quote Quick reply to this message
Old 30-12-13, 10:52 PM   #5
mac
Inactive User
 
Join Date: Dec 2013
Location: Newcastle Upon Tyne
Posts: 9
Default

Ahh thanks for that Mark.
I shall ask tomorrow and see about those scanners you mentioned.

Would that sensor being faulty be enough to put the light on and off when it feels like it?
Ive noticed the car seems to drive ever so slightly better if I ease the throttle, if I just put my foot down it seems worse.

Cheers
mac is offline   Reply With Quote Quick reply to this message
Old 30-12-13, 11:01 PM   #6
Inactive User
 
Join Date: Dec 2013
Location: telford
Posts: 24
Default

theres a map somewhere with members who have it, i have it but am 3 hours from you, search planet map
mac likes this.
mark g is offline   Reply With Quote Quick reply to this message
Old 30-12-13, 11:11 PM   #7
mac
Inactive User
 
Join Date: Dec 2013
Location: Newcastle Upon Tyne
Posts: 9
Default

Thanks for the Advice Mark. Its very much appreciated
mac is offline   Reply With Quote Quick reply to this message
Old 30-12-13, 11:45 PM   #8
Inactive User
 
Join Date: Dec 2013
Location: telford
Posts: 24
Default

if you work on peugeots or intend to keep the car for a few years its worth looking into getting the interface and software to diy, i bought one from ebay for about 80 quid , but i found it was a sod to install as i am pre zx81.
mark g is offline   Reply With Quote Quick reply to this message
Old 31-12-13, 01:57 PM   #9
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,043
Default

If the 2 you tried did not light up then its not the equipment its the car no point seeking out planet till you get the socket working.

Maxidiag should read a 307 snap on stuff is very hit and miss with French cars as its Gucci aimed at Gucci cars
reliable406 is offline   Reply With Quote Quick reply to this message
Old 31-12-13, 02:58 PM   #10
mac
Inactive User
 
Join Date: Dec 2013
Location: Newcastle Upon Tyne
Posts: 9
Default

Found a blown 15 amp fuse earlier today.
I replaced it and the car now has power to the diagnostics socket
Unfortunately the only fault came back on the climate control, no other faults.
mac is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 03:43 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.