Anti Pollution Fault - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 22-01-14, 07:28 PM   #1
Inactive User
 
Join Date: Dec 2013
Posts: 62
Default Anti Pollution Fault

Hi, I have a rather strange fault with my 307 HDI 110. Im getting anti pollution fault coming up on the dash but only when I am at motorway cruising speed. I can be going along fine but after say 20-40 miles it flashes that up on the dash and I got no boost and no traction control. As soon as you turn the car off and back on everything is back to normal but the check engine light stays on for around 2 days after. I had it scanned by a mate. It's coming up with 7 Faults. P1138, Fuel Pressure Regulator
P0380 Pre Heating Relay Circuit
P0235 Turbo Pressure Signal
P1000 CAB Bus
P1458 Coolant Solenoid Valve
P0246 Turbo Preasure
P0100 Flow Sensor Signal.
Car is stock apart from no DMF and no DPF
I've tried several things to sort it like a new MAP sensor, air flow meter cleaner.
All hoses are in good condition and are connected. Really drawing a blank on it cause I can't understand why it does only when I am going along at 70. Any help would be really helpfull. Alex
alexp1604 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 22-01-14, 07:59 PM   #2
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,615
Default

I'd try a new MAF first. A faulty one can cause a number of those errors.

MAF cleaner doesn't really work, its self cleaning.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 22-01-14, 08:38 PM   #3
Inactive User
 
Join Date: Dec 2013
Posts: 62
Default

Thanks Gibbo! I'll try a new MAF tomorrow and take if for a run see what I get. Can you think of anything else that that could be causing it?
alexp1604 is offline   Reply With Quote Quick reply to this message
 
Old 22-01-14, 08:46 PM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,010
Default

we had this on a taxi and it was a vac pump fault brakes worked fine but vac dropped off when revved at a steady speed check vacuum if the maf does not help.
reliable406 is offline   Reply With Quote Quick reply to this message
Old 22-01-14, 09:51 PM   #5
Inactive User
 
Join Date: Apr 2009
Location: Mid Essex
Posts: 586
Default

Change the fuel filter and have the vacuum pipe circuit and all electro solenoids checked out
MadV is offline   Reply With Quote Quick reply to this message
Old 23-01-14, 07:34 AM   #6
Inactive User
 
Join Date: Oct 2013
Location: london se9
Posts: 15
Default

I had the exact same problem as you
Turned out the turbo pressure vaulve was duff. 50 from pugs and 5 mins to change it and it's been like a new car since and pulls like a train !!!
Hossradish likes this.
colinspence is offline   Reply With Quote Quick reply to this message
Old 25-01-14, 02:58 PM   #7
Inactive User
 
Join Date: Dec 2013
Posts: 62
Default

Right I came up with an excuse to go down to my aunts this weekend and the check engine light was off when I set off. After 70 miles it came up ESP/ASR not functioning and the anti pollution was also up there on the dash. I stopped at a services and as soon as I turned the car back on everything felt normal and but the the light was stayed on. I have replaced the MAF and taken it for a run but the light is still staying on! can't seem to get rid of it now and now the turbo doesn't seem to be coming on as strong as it was. Really doing my head in now cause a new MAP sensor was 40 and new MAF was 80 and when this fault comes on whilst driving it's really hard to overtake anything and stay at a decent speed. Any more help would be great
alexp1604 is offline   Reply With Quote Quick reply to this message
Old 25-01-14, 03:03 PM   #8
Inactive User
 
Join Date: Oct 2013
Location: london se9
Posts: 15
Default

Check the turbo boost solenoid. !!!!

Everything points to that. !!!
It's at the font/bottom of the car down by the radiator. There is 2 other solinoids there so swap 1 over and see if it works.

My car was the same when the anti pollution warning came up. It was limited to 3000rpm and had no guts in it !
Hossradish likes this.
colinspence is offline   Reply With Quote Quick reply to this message
Old 25-01-14, 03:34 PM   #9
Inactive User
 
Join Date: Dec 2013
Posts: 62
Default

I'll take a look at that tomorrow and see what happens
alexp1604 is offline   Reply With Quote Quick reply to this message
Old 25-01-14, 05:15 PM   #10
Senior Member
 
CMax_307's Avatar
 
Join Date: Aug 2008
Location: Belfast
Posts: 1,045
Default

you say no DPF/FAP? was this removed and turned off in the bsi?

another thing is check the wires on the turbo solenoid as these have a habit of breaking up the loom, but as the others say it looks like the solenoid you could swap it over with the egr one and road test it and see what it feels like
CMax_307 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:48 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.