Airbag fault P802 - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 05-01-13, 10:19 AM   #1
Inactive User
 
Join Date: Dec 2012
Location: Norfolk, UK
Posts: 13
Default Airbag fault P802

Hi, I have 2001 90bhp 2.0hdi 307 which has Airbag fault displayed and the airbag light stays on when driving. I have managed to get a good fault code reader on it and it gives P802 as the code. Clearing the error is no good as it returns straight away.
Anyone any ideas?
Regards
DC
DeuxChevaux is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-01-13, 02:47 PM   #2
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,512
Default

What reader are you using to get this code. P codes are normally only used for engine/power train are you sure that this code is related to airbag.

If possible find someone on the planet map and get the airbag codes checked again
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Old 06-01-13, 08:42 PM   #3
Inactive User
 
Join Date: Dec 2012
Location: Norfolk, UK
Posts: 13
Default

Thanks windy1603. Don't know the make but it is a very good one. My own is no match for it. I've searched the web for the meaning for the code P802 and it comes back with 'Ignition circuit driver side airbag stage 2 - open circuit' Yes the P codes usually come back with engine related things but not the 3 number codes which are airbag related, engine are usually 4 number codes.
So I guess its check all the driver side airbag wiring or its the dreaded Comm 2000 unit that has an issue.
Thanks for the response, anyone any specific ideas from this info?
DeuxChevaux is offline   Reply With Quote Quick reply to this message
 
Old 06-01-13, 09:04 PM   #4
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,512
Default

Drivers airbag is 99 times out of 100 related to connections or ribbon cable on comm2000. I have same fault on my 307.

I have removed the plug for faulty circuit connection from back of comm2000 and bridged with a 2.2 Ohm resistor to clear code and stop the car nagging me every time i start it up until i can source a secondhand com2000 or have time to try and repair ribbon cable (if possible).

If you want to test out ribbon disconnect battery for 15 mins. remove airbag and unplug airbag and disconnect airbag plugs from rear of comm2000, Blue and Green Plugs (these sockets contain shorting pins) so once plugs removed they short out ribbon cables. You can then test resitance at airbag connectors on steering wheel should be near 0 ohms on both circuits if not the open circuit should be as below.

Blue airbag connector to blue plug on left rear of comm2000 open circuit gives Trigger 1 error codes.

Green airbag connector to brown plug on right rear of comm2000 open circuit gives gives Trigger 2 error codes
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Old 07-01-13, 05:54 PM   #5
Inactive User
 
Join Date: Dec 2012
Location: Norfolk, UK
Posts: 13
Default

Thanks for that Windy1603, useful info, I'll let you know how I get on
DC
DeuxChevaux is offline   Reply With Quote Quick reply to this message
Old 14-01-13, 01:34 PM   #6
Inactive User
 
Join Date: Sep 2012
Location: Paisley, Scotland
Posts: 403
Default

Bit off subject but Im wondering if anyone here could tell me how I would go about fitting a resistor to wiring under front seats in my 206 ? As I recently had new frontseats put in that have no airbags or wiring. I have already bought some resistors but unsure how to fit it to this plug (pic attached) This is the only plug that comes from the car under the seats so im assuming this is the plug the resistor should be fitted to.
Attached Thumbnails
img_20130114_131841.jpg  
davie206 is offline   Reply With Quote Quick reply to this message
Old 30-01-13, 11:07 AM   #7
Inactive User
 
Join Date: Dec 2012
Location: Norfolk, UK
Posts: 13
Default

Sorry its taken so long to update but here goes. With the aid of some borrowed Peugeot test gear (plugs which fit on the connectors and contain a small resistor!) The fault was tracked down to the dreaded COMM 2000 unit, probably the ribbon cable. I bought a new Valeo unit from EuroCarParts. Their list price is 137.79 but with the 'parts25' discount code it brought the cost down to 96.48. Its just been fitted and now no airbag fault!
DeuxChevaux is offline   Reply With Quote Quick reply to this message
Old 01-03-13, 07:35 AM   #8
Inactive User
 
Join Date: Apr 2012
Posts: 23
Default

Windy - thanks for you post about testing and bridging; can I clarify that I have understood it correctly.

I have the airbag fault that pp2000 indicates is the drivers airbag level 2 open circuit etc, which I gather is typically the comm2000.

I'd ideally like to test this unit first before replacing and your idea of a temporary bridge to clear the code would be good while I track one down.

Thus far I have only gone as far as removing the steering column shroud and the airbag. I can see the blue and green plugs connecting the airbag to the hub/wheel. I presume the fault is typically in these ribbon cables.

Would I be right in assuming that when I take the comm2000 off I will find blue and brown plugs (amongst other connectors) between the unit and the car/wiring loom? From your post, I gather that I should test the resistance between the front and rear connectors of the comm2000, matching blue to blue and green to brown, and that I should see no real resistance in these if the connections are ok, and inf resistance if there is an open circuit (break in cable) I'm hoping that this should confirm the source of my problem.

I'm also presuming that your bridging technique involves placing the resistor across either the blue or brown connectors on the cable coming from the car. So, in effect I leave the relevant cable disconnected from the rear of the comm2000. Does this then close the circuit and clear the fault (making the ecu think the air is present) Would you recommend removing the other airbag cable and doing the same, or leave this in place?

Just out of curiosity; when I've tried to clear this fault in pp2000 (admittadly before tying to fix the problem) it doesn't behave the same as when I have cleared other faults. Rather than going through the motions of asking for mileage and requiring the ignition to be switched of (as with ecu codes), it instead just flashes for a moment and then goes back to showing the code. Obviously this might just be airbag ecu behaving differently and detecting immediately the presence of the fault again; but I'd be curious of your experience.

Thank you very much for your help in the post and help you provide in response to this message!
wildej is offline   Reply With Quote Quick reply to this message
Old 01-03-13, 02:00 PM   #9
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,512
Default

Yes what you say is fine due to the shorting clips in the comm2000 sockets the car loom plugs in on (Brown & Blue connectors) you can just unplug the loom plugs and the do the test across the two terminals at the air bag plugs open circuit would show a defective ribbon.

I left the working airbag circuit connected as i thought it would be better to have half a airbag work than none (which is the case when the light is on both squibs disconnected) and just plugged the resistor into the car loom plug and stuck a bit of insulating tape over it and taped the plug to the loom short term to put light out
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
Old 01-03-13, 02:14 PM   #10
Inactive User
 
Join Date: Apr 2012
Posts: 23
Default

Oh I see! So the shorting clips are within the plugs on the back of the Comm2000 unit? I was confused initially and thought the shorting clips were on the front connectors of the Comm2000 (The ones the airbag connect to).

So you are saying that these clips should (if there are no breaks in the ribbon) form a complete circuit between either side of the same plug on the front of the Comm2000 (Where the airbag connects), therefore essentially creating a loop through the Comm2000 from the front, through the shorting clips on the rear and back to the other side of the same plug?

I hadn't appreciated that the Comm2000 units role was simply to pass a pair of wires through from the loom to the airbag. I assumed that the unit had some sort of control or signal function and that the unit itself would connect to the loom with a multi-plug or something.

Much appreciated. I might finally be able to convince myself to buy a new Comm2000 and maybe get rid of that annoying light in the mean time. Actually, it is less the light and more the annoying MFD message, which comes on every time I dare to control the wipers myself.

Cheers
wildej is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:54 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.