Air temp sensor - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 28-08-18, 11:26 PM   #1
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default Air temp sensor

I have just acquired a 2002 307 with a EW10J4 RFN motor and auto AL4 box.

It has a major oil leak from somewhere up behind the motor. As yet I have not got it onto my hoist to see if I can find the source. Any common sources for leaks on the rear of this motor? First time I have had a petrol 307 so completely unfamiliar with this motor.

Also, had a suspected gearbox failure, was in limp mode and locked in gear. Was very difficult to shift out of park. i did a PP2000 scan and found no communication with the gearbox ecu. Discovered this ECU is placed behind the battery and completely unprotected from the elements...!!! Should it have some sort of cover? Surely..??

In any case, I removed it, inspected the pins and found corrosion on some. Not surprising seeing that the ecu plug faces up so would be a trap for any water floating around in the engine bay.. Cleaned all the pins and terminals up and all faults gone, test drive was good with smooth shifting and no faults on return. Previous owner's 'mechanic' had advised that gearbox was shot and needed replacing... I could see from visual evidence that the ECU had never been disturbed or the plug removed/replaced. My guess is that he didn't even know where the ECU was.. far too many bush mechanics over here unfortunately.

When I did a live scan, found the air temp was reported as 136C. Water temp started off very high [over 100C] but slowly settled down to a believeable setting. So may be faulty. The air temp one is obviously faulty.. Which sensor reports air temp on this motor to PP2000? Looking in Servicebox I suspect it would be the one on the side of the throttle body, part number 1920-8Y. Correct?

Any help/suggestions appreciated.
WillNZ is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 03:14 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.