307 starting problems. - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 26-06-17, 12:46 PM   #1
Junior Member
 
Join Date: Jun 2017
Posts: 13
Default 307 starting problems.

Hello all. I am currently working on a 2006 307 SW 1.6HDI.
Problem being that "ABS faulty" comes up on the screen and the car wont start. When this happens DiagBox will not communicate with ABS or power steering ECUs. Fault codes are:
F4C3- Brake fluid level.
B9B7- Engine relay unit, Ignition +ve relay or harness
9651 (airbag)- supply voltage ignition controlled +ve
7150- Vehicle speed info.
If car isn't going to start, can take key, out lock and unlock then turn over straight away it will start, with no lights or codes.
I am thinking engine relay unit or wiring, but unsure where to start.
Any help appreciated.
WallsA7X is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-06-17, 03:59 PM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,037
Default

Most likely a bad wiring connection somewhere
Underbonnet fusebox fault is possible too
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 26-06-17, 04:05 PM   #3
Junior Member
 
Join Date: Jun 2017
Posts: 13
Default

Thanks for replying.
That's what I feared, thought I'd see if there were any other likely causes before going in to the wiring.
WallsA7X is offline   Reply With Quote Quick reply to this message
 
Old 17-08-17, 07:40 AM   #4
Junior Member
 
Join Date: Jun 2017
Posts: 13
Default Fixed!

Been off here for a while. Turned out to be a bad relay inside the engine bay fuse box.
WallsA7X is offline   Reply With Quote Quick reply to this message
Old 17-08-17, 07:08 PM   #5
Senior Member
 
Join Date: Sep 2016
Location: Stoke on Trent
Posts: 1,795
Default

Which relay was it?
madbadandold is offline   Reply With Quote Quick reply to this message
Old 17-08-17, 07:11 PM   #6
Junior Member
 
Join Date: Jun 2017
Posts: 13
Default

Sorry not sure. Auto electrician found it. Just said it was an internal relay in the fuse box.
WallsA7X is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:30 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.