307 problem any help - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 31-01-13, 12:04 PM   #1
Inactive User
 
Join Date: Dec 2012
Posts: 3
Default 307 problem any help

hi all, i have a peugeot 307 2.0hdi 90bhp model with 93000 miles on the clock and i have an issue at the moment and is really pissing me. the thing is me when you 're on 4 gear doing about 30 mph and then you press more the pedal and the engine starting knocking that you have to lift off and press the pedal in slow and sometimes than is ok and sometimes you have to change gear in depends on the road like if your going up a hill or not. did someone experience this problem?
any help ?
ybt200 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 31-01-13, 12:26 PM   #2
Inactive User
 
Join Date: Mar 2012
Posts: 90
Default

Engine mounts I reckon.

the large top one on the left of the engine (if you're standing looking at the engine from the front) and probably the rear one, down the back of the engine.

The one under the battery doesn't seem to get as much abuse as those 2.

I got mine from Mister Auto. They got some crap reviews online, but I've used them twice and had no problems at all. The large top engine mount Peugueot want just shy of 100 for, I got it for 45 - proper Lemforder one as well. Other ones were equally as cheap and the same brand.
RussHDI is offline   Reply With Quote Quick reply to this message
Old 31-01-13, 12:50 PM   #3
Senior Member
 
Join Date: Aug 2012
Location: Torquay
Posts: 437
Default

4th gear at 30mph and trying to accellerate in a 90bhp.

Try it in 3rd gear at 30mph and accellerate. Do you still get the knocking?
__________________
[COLOR="Silver"]106 Quiksilver 2003
807 GLX 2.0 PETROL AUTO 2004[/COLOR]
Roky is offline   Reply With Quote Quick reply to this message
 
Old 31-01-13, 01:24 PM   #4
Inactive User
 
Join Date: Dec 2012
Posts: 3
Default

i think the problem is more coming from the engine , maybe there's a sensor or the egr not the mountings?
ybt200 is offline   Reply With Quote Quick reply to this message
Old 31-01-13, 06:23 PM   #5
Inactive User
 
Join Date: Jan 2013
Location: Nottingham (pinxton J28 M1)
Posts: 399
Default

Quote:
Originally Posted by Roky View Post
4th gear at 30mph and trying to accellerate in a 90bhp.

Try it in 3rd gear at 30mph and accellerate. Do you still get the knocking?
I was just about to say that!
I have the same 2.0hdi 90 and I can't put mine in 4th @ 30mph if I do the revs are too low and it struggles like mad!
I just drive in 3rd @ 30mph
__________________
307 2002 2.0 HDI 90
willhenshaw is offline   Reply With Quote Quick reply to this message
Old 31-01-13, 10:47 PM   #6
Inactive User
 
theMDJ's Avatar
 
Join Date: Jun 2012
Location: Alsager, Nr Crewe
Posts: 29
Default

i cant suggest anything different but if you were to get mounts then theres a informative thread above about fitting superior powerflex mounts..
theMDJ is offline   Reply With Quote Quick reply to this message
Old 01-02-13, 11:28 AM   #7
Inactive User
 
Join Date: Dec 2012
Posts: 3
Default

mine is chipped and it really made the difference from standard so it is about 115 bhp now ,thats why i said on 30 mph .

Last edited by ybt200; 01-02-13 at 11:34 AM.
ybt200 is offline   Reply With Quote Quick reply to this message
Old 01-02-13, 07:06 PM   #8
Senior Member
 
Join Date: Jul 2012
Posts: 3,415
Default

Quote:
Originally Posted by willhenshaw View Post
I was just about to say that!
I have the same 2.0hdi 90 and I can't put mine in 4th @ 30mph if I do the revs are too low and it struggles like mad!
I just drive in 3rd @ 30mph
i used to regularly drive mine at 30 in 5th lol. i have changed my habits now im sure my mpg is better as well
monty9120 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 03:24 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.