307 hdi no turbo - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-11-11, 10:52 AM   #1
Inactive User
 
Join Date: Nov 2011
Posts: 4
Default 307 hdi no turbo

Hi ,
i have 307 2.0l hdi sw 2004 plate.

car lacks power and can't hear turbo - peugot planet diagnostic c/o and shows 2 permanent faults
1/ engine ecu-permanent fault -turbo pressure-turbo pressure measured too low
2/ engine ecu- permanent fault - egr air circuit fault airflow measured less than recommended.

have physically checked vacuum pipes - all seem ok
have noticed some oil in intercooler although there was evidence of this before turbo stopped working.

peugot garage have had car for a week and say all is ok / normal !
local garage have agreed turbo is definatel not working.

I am looking for any ideas as am myself an engineer and can do most tasks,
and also looking for an experienced peugot mechanic in south cambs/north herts area sg85ht.

Thanks
davewil is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-11-11, 07:42 AM   #2
Senior Member
 
Join Date: Mar 2010
Location: Haslingfield,cambridge
Posts: 405
Default

De Freville Engineering


Will try and find out some gen for you Dave.
__________________
retrofit cruise control
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zooankski is offline   Reply With Quote Quick reply to this message
Old 07-11-11, 08:17 AM   #3
Senior Member
 
Join Date: Mar 2010
Location: Haslingfield,cambridge
Posts: 405
Default

https://www.peugeotforums.com/forums/...o-power-17369/

sounds about right to me
__________________
retrofit cruise control
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zooankski is offline   Reply With Quote Quick reply to this message
 
Old 08-11-11, 01:26 PM   #4
Inactive User
 
Join Date: Jul 2011
Posts: 34
Default

Quote:
Originally Posted by zooankski View Post
Ill second what is said about the solenoids in this thread. I had the same thing a few weeks ago - i didnt have the egr fault, but the 'turbo pressure measured too low' was there. I spent ages trying to find leaks, sucking on vacuum hoses etc etc, then replaced the solenoid that provides the vacuum to the wastegate, back to normal There is 2 solenoids, im not sure exactly the purposes of the other one, but i wouldnt be surprised if one or both of these failing would bring up the egr fault as well.
stuart.mac is offline   Reply With Quote Quick reply to this message
Old 11-11-11, 06:49 PM   #5
Inactive User
 
Join Date: Nov 2011
Posts: 4
Default

Thanks Stuart - have always suspected these solenoids - can you give location on engine -thanks
davewil is offline   Reply With Quote Quick reply to this message
Old 11-11-11, 08:28 PM   #6
Inactive User
 
Join Date: Aug 2011
Posts: 12
Default solinod

hi there the one you want is just beind the rad in the midel at botom of engine with two pipes one gowing to vac pump the uther one gowing under the engine to the turbo ad the same falt .
markowl is offline   Reply With Quote Quick reply to this message
Old 29-11-11, 11:46 AM   #7
Inactive User
 
Join Date: Nov 2011
Posts: 4
Default

i have just replaced turbo solenoid , but still no fix
davewil is offline   Reply With Quote Quick reply to this message
Old 02-12-11, 05:12 PM   #8
Senior Member
 
CMax_307's Avatar
 
Join Date: Aug 2008
Location: Belfast
Posts: 1,045
Default

did you make sure the vac pipes are on the right way vac to vaccum and out to your turbo ? ive been caught out few times myself lol
CMax_307 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:31 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.