307 HDI Loss of power plus smoke - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By noddy-hol

Reply
 
LinkBack Thread Tools Display Modes
Old 22-06-17, 08:50 AM   #1
Junior Member
 
Join Date: Jun 2017
Posts: 10
Default 307 HDI Loss of power plus smoke

Hi all Iím extremely new here so sorry if this is in the wrong place. I canít quite find what Iím looking for so wanted to start my own thread. I have a 307 1.6 HDI diesel on a 07 plate, 170,000 on the clock and until lately has been perfect.
Last week I noticed a loss of power mostly on hills but it was intermittent then last night when I pulled up at some lights I noticed a small amount of smoke from under the bonnet, I checked and no fires!! Iíve also notice a strong smell of fumes outside the car but Iím 99% sure itís not an injector as I had these done a couple of months ago and canít see any of the signs that would suggest this. Also no lights or warnings on the dash. The loss of power now seems to be all the time. Please can anybody help? I know sheís old but without her Iím really stuck and would really appreciate some help and advice.
averylew is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 22-06-17, 10:21 AM   #2
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,146
Default

It sounds like the injector seals need a close look at as they were disturbed before and a possible diesel leak.I have traced fumes by running the engine when its dark and using a torch followed the fumes to the source...hope that helps and good luck..
averylew likes this.
noddy-hol is offline   Reply With Quote Quick reply to this message
Old 22-06-17, 10:27 AM   #3
Senior Member
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,825
Default

Live data on PP2000 may help if you can't find see anything immediately obvious
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
 
Old 22-06-17, 11:44 AM   #4
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,146
Default

ps....exhaust manifold gasket will be worth a look?
noddy-hol is offline   Reply With Quote Quick reply to this message
Old 22-06-17, 11:51 AM   #5
Junior Member
 
Join Date: Jun 2017
Posts: 10
Default

Thanks for the advice so far. I like the torch idea so looks like it’s gunna be a late night for me tonight. Also I went out at lunch and revved her up and if I gradually increase reves it gets to 3200 then drops back to 3000 and just bounces between the two but if I apply more pressure to pedal the revs go up but feels lumpy. ( I can feel a jerk / heavy vibration through the car) any further ideas?
averylew is offline   Reply With Quote Quick reply to this message
Old 28-06-17, 12:22 PM   #6
Junior Member
 
Join Date: Jun 2017
Posts: 10
Default

A little update on this one, I ended up with the dreaded anti-pollution warning so from reading on here I started my investigations. First off, I checked turbo and clamps, all ok, then I had the fuel filter off, no problems there, then I noticed the breather from the crank shaft into the inlet pipe was lose. So as a temp fix to see if this could have been the problem, I pushed the breather tight in and have duct tapped in place and hay presto, no more anti-pollution or engine light. I have a long run with the hill I first noticed the issues on tonight so I’ll update how it is then work a permeant fix out if its cured.
averylew is offline   Reply With Quote Quick reply to this message
Old 28-06-17, 01:55 PM   #7
Senior Member
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,825
Default

The breather is a poor design on this engine, it isn't a tidy fit at all. Hopefully the gaffer tape has sorted it for you
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:33 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.