307 electrical/ wire fault - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-08-17, 12:29 PM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 1
Default 307 electrical/ wire fault

I am a new driver and this is my first car.... I am quite clueless about cars, will appreciate any advice please...mine is a 307, 2007, petrol, automatic, 1600cc.

The problems of my car:

Main problem:

In the past month (since I bought the car from a trader in Reading), twice I couldn’t start the car and needed to start the engine by jumping the battery. Initially I thought it was the problem of the battery but the guy from Halford told me that my battery seems fine. I went to check the starter, any my starter seem fine too and the garage said it could be a electrical problem which they couldn't really confirm as they don't have the machine for that.

I have other (minor) very possibly related issues with the car:

1.Occasionally, when I start the engine, some or all the error lights will go up, sometime the engine’s one too… If this happens, my headlight and screen wiper will be switched on automatically and needed to be switched on and off to switch them off.


2.I have replaced the battery in my key remote and try to sync it to my car using ways suggested online, but it still doesn’t work… not sure if there is anything I could do about it.


3.Central lock: to unlock the all doors of my car, I have to put the key in and turn to the non-engine-starting position, is that normal? With the key itself, without plugging it into the ignition place, I could only open the driver door (I thought all doors will be unlocked, but I am not sure if my car should do that as it is a fairly old model).


4.Radio’s time and date always reset itself after each drive

I will be ultra grateful for any advice... hope can resolve my problems without costing lotssss
kimwhy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-08-17, 09:41 PM   #2
Senior Member
 
Join Date: Jul 2017
Location: Glenrothes
Posts: 718
Default

Hi,

Have you tried disconnecting and reconnecting the battery using the proper procedure?

Also maybe try reseting the bsi to see if that sorts some of the issuses your having

BSI Reboot and Method for Disconnecting/connecting the battery

BSI Reboot Process for Peugeot - United Kingdom | BBA Reman

Regards Terry
__________________
Peugeot 307xsi 2.0hdi 110bhp 2004.
terry57 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:18 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.