307 dash clocks fault! - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 17-11-11, 07:26 PM   #1
Inactive User
 
Join Date: Nov 2011
Posts: 1
Default 307 dash clocks fault!

Hi my girlfriend bought a 307 but when driving along suddenly all the dash warning lights come on and stop light flashes, however the speedo drops to zero so do the revs and fuel the trip counter and miliage counter are all blank.. also noticed that hazzord light switch and central locking button on the dash Doesn't work when this happens.. but when we turn car off it will stay on for a few mins then reset itself for a while longer has any1else had this problem? Thanks also noticed its only when the passengers air deactivation light comes on even though we havent turned it off!!
markymarkni is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 18-11-11, 05:58 PM   #2
Inactive User
 
Join Date: Mar 2011
Location: Kingsway, Quedgeley, Gloucestershire/Wolverhampton, Staffordshire
Posts: 405
Default

Does the car keep running, or does everything die? Sounds electrical (duh) or computer
__________________
[COLOR="Gold"]307 1.6 Rapier Gold [/COLOR]:)
[COLOR="Blue"]307 2.0 XSI Blue[/COLOR] (Dead)
Mellkat86 is offline   Reply With Quote Quick reply to this message
Old 20-11-11, 04:53 AM   #3
Senior Member
 
Join Date: Apr 2010
Location: Ringwood,Hampshire
Posts: 320
Default

Sounds like you need to find someone near you with planet and hook it up and see if it brings up any faults,then go from there.Take a look at the map and see if there is someone near you that could help. or even update your profile with your location
__________________
Peugeot 307 XSI petrol 138
matt268uk is offline   Reply With Quote Quick reply to this message
 
Old 20-11-11, 09:27 AM   #4
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,622
Default

I had this on a 306. It was a corroded earth strap from the battery to the bodywork.

Not saying that this will be the fix for you but well worth a check. I've seen many rusty connections on 307s over the years.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:38 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.