307 2.0 HDi power loss ?! - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 21-12-12, 10:46 PM   #1
Inactive User
 
Join Date: Dec 2012
Location: somerset UK
Posts: 7
Default 307 2.0 HDi power loss ?!

Hi Forum Members,

I have Peugeot 307 estate 2.0 HDi 110bhp 53 reg. I bought it 5 weeks ago and suddenly car is loosing power?! I was driving on motorway and lost power and warning light came on dashboard:



Then the next day car was fine, normal power, no warning lights...soon the day after same fault again..Don't know whats is going on, problem is keep coming back and disappearing ...?!?! Car has 84k on the clock and MOT was recently done without any problems.

Please help pointing me into right direction


Many Thanks
Antony
smithy27 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 22-12-12, 09:03 AM   #2
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,621
Default

Any warnings on the centre screen? You'll probably need a diagnostic. Check the map thread to find someone close to you.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 24-12-12, 02:03 AM   #3
Inactive User
 
Join Date: Dec 2012
Location: somerset UK
Posts: 7
Default

center screen showing 'Anti-pollution fault'
smithy27 is offline   Reply With Quote Quick reply to this message
 
Old 24-12-12, 05:24 AM   #4
Senior Member
 
Join Date: Jul 2012
Posts: 3,415
Default

your particulate filter may be blocked or you eloys liquid bottle may be empty
monty9120 is offline   Reply With Quote Quick reply to this message
Old 24-12-12, 09:58 AM   #5
davidireland
Guest
 
Posts: n/a
Default

Get a diagnostic check done. No point guessing whats up.

Sent from my GT-S5690
  Reply With Quote Quick reply to this message
Old 24-12-12, 10:07 AM   #6
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,621
Default

Agree with David, it could be literally 50 things, from a blocked particulate filter, to faulty MAF sensor to dodgy injector.
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 02-01-13, 08:06 PM   #7
Inactive User
 
Join Date: Dec 2012
Location: somerset UK
Posts: 7
Default

Hi,

Thanks for your advice, I've done diagnostic check and unfortunately my problem is a result of two apparently 'common faults':

- first particulate filter blocked

- faulty EGR valve

I've checked my local Peugeot dealer and price for new filter is 405.66 - is not that bad ....but from what I found on forums removing particulate filter could bring some benefits

Should I replace that filter or remove it completely from the exhaust system?
Anyone had similar problems or some experience in that area?
smithy27 is offline   Reply With Quote Quick reply to this message
Old 02-01-13, 08:17 PM   #8
Senior Member
 
Join Date: Jul 2012
Posts: 3,415
Default

you can unblock them if your handy with a spanner
monty9120 is offline   Reply With Quote Quick reply to this message
Old 02-01-13, 08:23 PM   #9
Inactive User
 
Join Date: Dec 2012
Location: somerset UK
Posts: 7
Default

what you mean with spanner?! just push something through ? I thought is much more complicated operation...but that sounds good (cheap option)

Local dealer advised my to try regeneration - to drive under certain circumstances... - done it just before xmas but problem came back...
smithy27 is offline   Reply With Quote Quick reply to this message
Old 03-01-13, 06:22 AM   #10
davidireland
Guest
 
Posts: n/a
Default

Remove and powerwash out. Simple. 400 saved.

Sent from my GT-S5690
Gibbo and windy1603 like this.
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:46 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.