307 2.0 HDI Fault codes - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree4Likes
  • 2 Post By eoptio
  • 1 Post By reliable406
  • 1 Post By reliable406

Reply
 
LinkBack Thread Tools Display Modes
Old 13-07-19, 10:31 AM   #1
Junior Member
 
Join Date: Nov 2018
Posts: 19
Default 307 2.0 HDI Fault codes

Hello all

I have a 2003 307 2.0 HDI FAP, RHS engine. I ve just got back from a longish motorway trip where the engine management light came on twice. After stopping and a few restarts the light went off again both times. No messages on the display and car is not in limp mode. I've read the fault codes and they are as follows:

P0402 --- EGR valve; positive deviation
P0246 --- Turbo pressure; pressure measured too low
P1421 --- Catalytic converter 1; upstream temperature signal, short circuit to earth
P1425 --- Catalytic converter 1; downstream temperature signal, coherence between converter 1 and 2 temperature
P1132 --- Fault on catalytic converter upstream and downstream temperature sensors

the first three I have had in the past with no engine light coming on. The last two I ve not had before. Car has done approx 175k miles. FAP/DPF regenerations are happening and the FAP/DPF fluid has recently been topped up by Peugeot. DPF was changed at around 125k miles by Peugeot.

Any suggestions as what the problem might be?

Thanks
eoptio is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 14-07-19, 02:03 PM   #2
Junior Member
 
Join Date: Nov 2018
Posts: 19
Default

Hello

had a further look around today and found a split in the intercooler pipe and a broken vacuum hose connection, which may explain some of the fault codes. I ll replace the intercooler pipe and see if that resolves the issue.
Gibbo and madbadandold like this.
eoptio is offline   Reply With Quote Quick reply to this message
Old 26-07-19, 11:49 AM   #3
Junior Member
 
Join Date: Nov 2018
Posts: 19
Default

just an update in case it might help others, I replaced the split intercooler pipe (top one), erased fault codes and have driven 1000 miles or so since.
P0402 --- EGR valve; positive deviation
P0246 --- Turbo pressure; pressure measured too low
P1132 --- Fault on catalytic converter upstream and downstream temperature sensors

faults have not come back sofar,

P1421 --- Catalytic converter 1; upstream temperature signal, short circuit to earth
P1425 --- Catalytic converter 1; downstream temperature signal, coherence between converter 1 and 2 temperature

are still coming back. Sofar the engine management light has not come on again, DPF has been regenerating every 300 miles or so. Any suggestions as to what the issue setting code P1421 and P1425 might be?

Thanks
eoptio is offline   Reply With Quote Quick reply to this message
 
Old 26-07-19, 11:54 AM   #4
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,909
Default

1st cat code is the cause of the 2nd cat code as basically second code is saying the 2 readings are not correct and this is because the first reading is not correct check the wiring before attempting to replace anything
madbadandold likes this.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 26-07-19, 12:31 PM   #5
Member
 
Join Date: Apr 2017
Location: Sarajevo, Bosnia
Posts: 47
Default

What's with theP0246 --- Turbo pressure; pressure measured too low , have you checked about it with the mechanic, I personally wouldn't play with any turbo codes
liaar is offline   Reply With Quote Quick reply to this message
Old 26-07-19, 12:56 PM   #6
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 13,909
Default

Thats just telling you what you already know its not boosting fully most likely because of the other faults !

He fixed that anyway.
madbadandold likes this.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:11 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.