307 2.0 Hdi 110 Bhp, what rpm does the turbo kick in? - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-02-13, 07:11 PM   #1
Inactive User
 
Join Date: Jan 2013
Posts: 59
Default 307 2.0 Hdi 110 Bhp, what rpm does the turbo kick in?

Hello, I've had a few faults with my car lately and I'm trying to get it back fighting fit, I've had to replace the turbo solenoid and have the fap filter cleaned out, I've had a new brake switch but haven't had it back on peugeot planet to try and clear the faults, when I start the car and its cold I can't get over 2k revs and then when it warms up I get all revs, I put my foot down and the turbo will kick in about 3500rpm is this normal? Or should it be earlier?
Thanks tom
Thomasjw is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-02-13, 07:22 PM   #2
Senior Member
 
Join Date: Jul 2012
Posts: 3,415
Default

mine is about 1800 revs i think
monty9120 is offline   Reply With Quote Quick reply to this message
Old 01-02-13, 07:34 PM   #3
Inactive User
 
Join Date: Jan 2013
Posts: 59
Default

Quote:
Originally Posted by monty9120 View Post
mine is about 1800 revs i think
Does it? There must be a problem somewhere that's stopping it from doing it earlier
Thomasjw is offline   Reply With Quote Quick reply to this message
 
Old 01-02-13, 07:38 PM   #4
Inactive User
 
Join Date: Jan 2013
Location: barnsley
Posts: 593
Default

Quote:
Originally Posted by Thomasjw View Post
Does it? There must be a problem somewhere that's stopping it from doing it earlier
u need to clear the faults from pu planet.
, if all else fails remove the maf sensor wire. try that. no fix? unplug egr and maby get it cleaned or blanked off.

i would say it would be fixed following a fault clear proccess onpp2000.

but if it didnt the maf sensor would be next on the list.

with the problem being when its cold, the air temp sensor (MAF)
or fuel temp sensor.
__________________
:nod::thumb::lol:
jack307 is offline   Reply With Quote Quick reply to this message
Old 01-02-13, 07:51 PM   #5
Inactive User
 
Join Date: Jan 2013
Posts: 59
Default

Quote:
Originally Posted by jack307 View Post
u need to clear the faults from pu planet.
, if all else fails remove the maf sensor wire. try that. no fix? unplug egr and maby get it cleaned or blanked off.

i would say it would be fixed following a fault clear proccess onpp2000.

but if it didnt the maf sensor would be next on the list.

with the problem being when its cold, the air temp sensor (MAF)
or fuel temp sensor.
How easy is it to get to the egr valve? I've seen the blanking of plates for the egr are they worth getting or just stick with the egr? If the maf sensor was faulty would it come up on PP?
Thanks tom
Thomasjw is offline   Reply With Quote Quick reply to this message
Old 01-02-13, 07:57 PM   #6
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,043
Default

Maximum boost is achieved at around 1800 rpm but to be accurate the turbo is boosting from 1000 rpm
reliable406 is offline   Reply With Quote Quick reply to this message
Old 01-02-13, 07:59 PM   #7
Inactive User
 
Join Date: Jan 2013
Posts: 59
Default

Quote:
Originally Posted by reliable406 View Post
Maximum boost is achieved at around 1800 rpm but to be accurate the turbo is boosting from 1000 rpm
Do you have any idea why mg car isn't boosting until 3500 rpm? Thanks
Thomasjw is offline   Reply With Quote Quick reply to this message
Old 02-02-13, 02:56 PM   #8
Inactive User
 
Join Date: Jan 2013
Posts: 59
Default

Can anybody help its driving me crazy when I'm driving
Thomasjw is offline   Reply With Quote Quick reply to this message
Old 15-03-13, 01:14 PM   #9
Inactive User
 
Join Date: Sep 2011
Location: dudley wmids
Posts: 60
Default 307

i had same mine was maf lots better now
fathead is offline   Reply With Quote Quick reply to this message
Old 15-03-13, 10:15 PM   #10
Junior Member
 
Join Date: Jan 2013
Posts: 24
Default hi

mines 1800 aswell you feel it boost i would say its the sensor on the air box pipe did it on a citreon c8 i had
Nasir2k9 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 10:50 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.