307 1.6 16v 2005 55 plate - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-02-14, 08:43 PM   #1
Inactive User
 
Join Date: Feb 2014
Posts: 4
Default 307 1.6 16v 2005 55 plate

hi all

can any one help

i have a 307cc 1.6 16v 2005 55 plate

it keeps puting up mill light ,p0341 and sometime depolution fault (not allways )
car runs fine starts fine etc

have changed pre cat lambda
crank sensor
still no jot driving me mad i know that p0341 says cam sensor but acording to pug there is no cam sensor on a 1.6 petrol

any help would be really good thanks in advance

cath
crazy cath is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-02-14, 09:17 PM   #2
Inactive User
 
Join Date: Sep 2013
Posts: 190
Default

Is it an old fault at all? On my 307cc it showed the same fault but there was nothing wrong with the cam sensor at all.
melosv8man is offline   Reply With Quote Quick reply to this message
Old 05-02-14, 09:22 PM   #3
Inactive User
 
Join Date: Feb 2014
Posts: 4
Default

thanks for the reply i have cleared this 3 times now but still pops back up !!!

is yours a 1.6 do you have a cam sensor peugeot tell me they only exsisit on the 2.0
crazy cath is offline   Reply With Quote Quick reply to this message
 
Old 05-02-14, 09:32 PM   #4
Senior Member
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,905
Default

Haynes manual agrees with Peugeot that on petrol engines only the 2.0 L engine has a cam sensor
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is offline   Reply With Quote Quick reply to this message
Old 05-02-14, 10:35 PM   #5
Inactive User
 
Join Date: Apr 2009
Location: Mid Essex
Posts: 586
Default

I suspect that you need to check you cambelt timing first to see if all is well. Then check all the spark plugs are okay. This should be a NFU engine which P0341 means ignition phasing coherence which means its probably the coil pack that is shot but best check the other two first.
MadV is offline   Reply With Quote Quick reply to this message
Old 06-02-14, 07:40 AM   #6
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,621
Default

https://www.peugeotforums.com/forums/...gnostic-28190/
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 06-02-14, 04:28 PM   #7
Inactive User
 
Join Date: Feb 2014
Posts: 4
Default

thanks for the reply
just had cam belt done but this was showing this fault befor belt was changed ?
crazy cath is offline   Reply With Quote Quick reply to this message
Old 06-02-14, 08:51 PM   #8
Inactive User
 
Join Date: Apr 2009
Location: Mid Essex
Posts: 586
Default

Then change the coil and plugs
MadV is offline   Reply With Quote Quick reply to this message
Old 07-02-14, 07:33 PM   #9
Inactive User
 
Join Date: Feb 2014
Posts: 4
Smile update

changed coil pack today
cleared fault code with pp
all seems to be fine no depolution fault no mill light thanks to everyone who replied

{coil on my car was a sagem know for playing up aparently}
crazy cath is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:00 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.