2006 307 reverse light problem - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 307
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 13-09-18, 08:37 PM   #1
Junior Member
 
Join Date: Sep 2018
Posts: 4
Exclamation 2006 307 reverse light problem

Help please :-)
I have a problem with my reverse light.
It comes on for 1 sec when reverse is selected then goes back off.
i have checked the fuse and changed the reverse switch.
Could this be a BSI problem ? would a reset sort the problem ?

thank you for taking the time to read
adewhiplash is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 13-09-18, 08:39 PM   #2
Junior Member
 
Join Date: Sep 2018
Posts: 4
Default

bulb has been replaced as well
adewhiplash is offline   Reply With Quote Quick reply to this message
Old 14-09-18, 07:16 AM   #3
Moderator
 
windy1603's Avatar
 
Join Date: Sep 2012
Location: Hertfordshire
Posts: 5,511
Default

Short together the two pins on the reverse light switch plug. If it all works OK you have either a new faulty switch, its wrongly fitted/wrong one or pin in gearbox which presses the switch has worn
__________________
DS5 & DS4 DSport 2.0 HDI 2012, 107 1.0 Urban 2006, 208 1.6 e-HDI Feline 2014, Suzuki RGV 250M 1989 (Money Pit)
windy1603 is offline   Reply With Quote Quick reply to this message
 
Old 14-09-18, 11:15 AM   #4
Junior Member
 
Join Date: Sep 2018
Posts: 4
Default

i have shorted the plug and it still does the same thing comes on and goes back off.
i have chased and tested the wiring loom from the bulb all the way back to the bsi. so i am thinking the start of a bad bsi or maybe a fault that a rest might sort ????
adewhiplash is offline   Reply With Quote Quick reply to this message
Old 14-09-18, 01:12 PM   #5
Senior Member
 
Join Date: Sep 2016
Location: Stoke on Trent
Posts: 1,796
Default

Are the bulb holder contacts clean and strong as are they gripping the bulb?. As the bulb lights and full power is drawn it might be too much for the contacts!
madbadandold is offline   Reply With Quote Quick reply to this message
Old 14-09-18, 04:20 PM   #6
Junior Member
 
Join Date: Sep 2018
Posts: 4
Default

Yes the bulb holder is fine. I have even used a 12v bulb tester along the wire and still same result, on then off again
adewhiplash is offline   Reply With Quote Quick reply to this message
Old 14-09-18, 04:52 PM   #7
Senior Member
 
Join Date: Sep 2016
Location: Stoke on Trent
Posts: 1,796
Default

Try the BSI reset as you first asked and see if that fixes it then.
madbadandold is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 05:33 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.