issues with 306 HDI - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 306
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-04-15, 09:09 PM   #1
Inactive User
 
Join Date: Apr 2015
Posts: 8
Default issues with 306 HDI

Recently put my peugeot 306 diesel hdi back on the road after being off road for a few years. Its passed its MOT, but it has some issues.

The engine management light is on, but all i get from the ecu is "no reply from ecu"

Also the wipers stutter and stop in the middle on the screen on some settings but work fine on others.

Last edited by sadpeugeot; 10-04-15 at 09:32 PM. Reason: spelling
sadpeugeot is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-04-15, 12:26 PM   #2
Inactive User
 
Join Date: Jan 2015
Location: Plymouth
Posts: 41
Default

Not so sure on the engine faults, but the wipers are a cheap fix.

It's the wiper parking sensor that has broken - easiest to just replace the whole wiper motor, (any 306 one will do from any phase). It's not too hard to change, just take off the wipers and then the black plastic trim below them and the motor comes off with just a few bolts.
__________________
307 110 1.6 HDI Estate
306 DT Estate - Retired
Amdhusband is offline   Reply With Quote Quick reply to this message
Old 11-04-15, 08:28 PM   #3
Inactive User
 
Join Date: Dec 2013
Location: Blackburn, Lancs.
Posts: 691
Default

What scanner are you using to read the Ecu ?
__________________
Peugeot 307 Sw, 2.0L, Hdi, 2004, 90bhp. Love it.
steve18gls is offline   Reply With Quote Quick reply to this message
 
Old 11-04-15, 09:49 PM   #4
Inactive User
 
Join Date: Apr 2015
Posts: 8
Default

I've used the lexia 3 device as well as a bluetooth adapter. Using the diagtool it can tell if i don't turn the ignition on but all i ever get back is no reply from ecu.

The mot place was also unable to find out the cause.
sadpeugeot is offline   Reply With Quote Quick reply to this message
Old 13-04-15, 01:06 PM   #5
Inactive User
 
Join Date: Apr 2015
Posts: 8
Default

I ran the peugeot on the motorway and it was limited to 70 at 2,500
sadpeugeot is offline   Reply With Quote Quick reply to this message
Old 16-04-15, 07:21 PM   #6
Inactive User
 
Join Date: Apr 2015
Posts: 8
Default

all of the fuses are fine, i've cleaned the contacts on the ecu. next would be checking the wiring from the obd port. If anyone has a wiring diagram that would be helpful, the ecu is a 3 plug type.
sadpeugeot is offline   Reply With Quote Quick reply to this message
Old 17-04-15, 09:09 AM   #7
Senior Member
 
trustme's Avatar
 
Join Date: Jan 2013
Location: bradford
Posts: 4,775
Default

Quote:
Originally Posted by sadpeugeot View Post
Recently put my peugeot 306 diesel hdi back on the road after being off road for a few years. Its passed its MOT, but it has some issues.

The engine management light is on, but all i get from the ecu is "no reply from ecu"

Also the wipers stutter and stop in the middle on the screen on some settings but work fine on others.
yo have not even stated what engine, I would check the cat has not blocked and pull the vacuum pipe of the egr and put a golf tee in the pipe to block it and see how it runs then
__________________
Great deals on car keys contact me 07599587119
trustme is offline   Reply With Quote Quick reply to this message
Old 17-04-15, 11:27 AM   #8
Inactive User
 
Join Date: Apr 2015
Posts: 8
Default

2.0 litre turbo diesel x reg hdi, the current issue isn't the engine, its the ecu isn't outputting data across the OBD2 port to enable diagnosis of the current issue/ clear the error to remove limp mode
sadpeugeot is offline   Reply With Quote Quick reply to this message
Old 24-04-15, 11:57 PM   #9
L.J
Member
 
Join Date: Apr 2015
Posts: 67
Default

from my experience when a known working code reader wont work it is down to faulty wiring from the ecu or a faulty ecu. ive had it happen to me a few times. check your wiring then see if you can lend an ecu of someone nearby maybe
L.J is offline   Reply With Quote Quick reply to this message
Old 30-06-15, 07:07 PM   #10
Inactive User
 
Join Date: Apr 2015
Posts: 8
Default

0 281 010 592
edc15c2 69
96 420 148 80


001211
28fm310
1166 0809
09211

these are the codes off the physical ecu, if any one has a guide to the wiring that would be helpful in identifying a dodgy wire, so i don't have to take the whole car apart to find a single wire fault

Last edited by sadpeugeot; 15-07-15 at 09:24 AM. Reason: hard to read numbers when its upside down and facing away
sadpeugeot is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:12 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.