306 diesel non-turbo - intermittent smoke & power loss under load - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 306
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-08-18, 11:28 PM   #1
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default 306 diesel non-turbo - intermittent smoke & power loss under load

Hi all,

Iíd really appreciate some thoughts on what might be going on with my 98 306 diesel, non-turbo, Lucas pump. Was running fine till I serviced it a couple of weeks ago, since when itís been losing power under load and smoking like a train - intermittently. Starts on the button; idles smooth.

Thereís a steep hill where I live. Sometimes itís struggling to make it up in 2nd, plumes of diesel-stinking smoke pouring out the back - then next time it will be pulling away in third or even fourth, clean as a whistle. I was driving home today and on inclines I could feel the power blip out now and then under my foot, with an accompanying cloud of smoke, and then it would kick back in again. Almost like it was missing here and there under load. Always under load.

What do people think? Air supply? Injection trouble? And is the fact that I just changed the fuel filter just a co-incidence? I replaced the fuel filter again today just in case - no change.

And the other question -should I keep driving it while itís misbehaving?

Thanks all.
Bruce.c909 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-08-18, 06:58 AM   #2
Senior Member
 
Join Date: Jul 2014
Location: Jersey CI
Posts: 2,364
Default

Not an expert, but I'd guess the EGR valve needs cleaning.
IanML is offline   Reply With Quote Quick reply to this message
Old 02-08-18, 08:04 AM   #3
Junior Member
 
Join Date: Aug 2018
Posts: 2
Default

Quote:
Originally Posted by IanML View Post
Not an expert, but I'd guess the EGR valve needs cleaning.
Thank you for the suggestion, Iíd wondered about that too, but Iíve checked it out and Iím pretty sure my engine doesn't have an EGR valve.
Bruce.c909 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:00 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.