Stereo stopped working/Multi function display stuck on mileage - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 26-01-13, 04:18 PM   #1
Inactive User
 
physio83's Avatar
 
Join Date: Jan 2013
Location: Kent
Posts: 4
Send a message via MSN to physio83 Send a message via Yahoo to physio83
Default Stereo stopped working/Multi function display stuck on mileage

Hello all

Overnight somehow my stereo has stopped working completely, no radio nor does it acknowledge a CD going in. It used to start as soon as I turned on the car.

Also, my centre console Multi-display has frozen on the mileage (where it tells you how many miles before re-fuelling). I have tried every button going to rectify this to no avail. Nothing in manual. The clock and date at the moment seem to be working fine.

Help!!
physio83 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 26-01-13, 11:11 PM   #2
Senior Member
 
m3mpower's Avatar
 
Join Date: Oct 2008
Location: Spain
Posts: 857
Default

Quote:
Originally Posted by physio83 View Post
Hello all

Overnight somehow my stereo has stopped working completely, no radio nor does it acknowledge a CD going in. It used to start as soon as I turned on the car.

Also, my centre console Multi-display has frozen on the mileage (where it tells you how many miles before re-fuelling). I have tried every button going to rectify this to no avail. Nothing in manual. The clock and date at the moment seem to be working fine.

Help!!

Try resetting the BSI and see if that helps
__________________
2014 5008 1.6 eHDi RT6

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
m3mpower is offline   Reply With Quote Quick reply to this message
Old 26-01-13, 11:19 PM   #3
Inactive User
 
physio83's Avatar
 
Join Date: Jan 2013
Location: Kent
Posts: 4
Send a message via MSN to physio83 Send a message via Yahoo to physio83
Default

OK....just read about the bsi...sounds rather difficult to me! Is this a major problem?
physio83 is offline   Reply With Quote Quick reply to this message
 
Old 26-01-13, 11:24 PM   #4
Senior Member
 
m3mpower's Avatar
 
Join Date: Oct 2008
Location: Spain
Posts: 857
Default

Quote:
Originally Posted by physio83 View Post
OK....just read about the bsi...sounds rather difficult to me! Is this a major problem?
It's not difficult, just follow the steps, it's just disconnecting the battery after all....
__________________
2014 5008 1.6 eHDi RT6

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
m3mpower is offline   Reply With Quote Quick reply to this message
Old 26-01-13, 11:30 PM   #5
Inactive User
 
physio83's Avatar
 
Join Date: Jan 2013
Location: Kent
Posts: 4
Send a message via MSN to physio83 Send a message via Yahoo to physio83
Default

OK I shall give that a go tomorrow and hope for the best. Thanks.
physio83 is offline   Reply With Quote Quick reply to this message
Old 27-01-13, 10:55 AM   #6
Inactive User
 
physio83's Avatar
 
Join Date: Jan 2013
Location: Kent
Posts: 4
Send a message via MSN to physio83 Send a message via Yahoo to physio83
Talking

Reset the BSI and IT WORKED (for now). Thank you so much for this information, who would have known disconnecting the battery was so complex!
physio83 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:46 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.