Peugeot 207 seems to have no power - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 16-12-17, 04:49 PM   #1
Junior Member
 
Join Date: Dec 2017
Posts: 1
Default Peugeot 207 seems to have no power

I put the key in the ignition and tried to start the car. After about half a second, power seemed to disappear completely from the car. Only the central locking button is flashing rapidly, nothing else is on. Pressing the unlock/lock buttons on the key does nothing to the car (tried main and spare key).
There is a clicking noise inside the car as well, even when the key is not in the ignition
Locking the car by inserting the key into the car door does not make the normal sound when locking the car, and the car lights do not flash, although the car does actually lock.

Last edited by Trooken; 16-12-17 at 04:57 PM.
Trooken is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 16-12-17, 06:01 PM   #2
Super Moderator
 
stevoxsi's Avatar
 
Join Date: Feb 2010
Location: N.Ireland
Posts: 1,731
Default

Try this. The beep test. Although it does seem like you have a very low battery.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Have owned: '00 Speedfight2 50cc '96 106 1.5d Escapade '97 306 1.9d D-turbo '99 306 1.9d D-turbo '03 307 2.0hdi 110 Rapier '06 307 2.0hdi 136 XSI '04 Peugeot 206 2.0hdi XSI
stevoxsi is offline   Reply With Quote Quick reply to this message
Old 16-12-17, 06:17 PM   #3
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

I would put money on the battery being u/s. Try charging it and get it load tested.
WillNZ is offline   Reply With Quote Quick reply to this message
 
Old 16-12-17, 06:21 PM   #4
Senior Member
 
Join Date: Sep 2016
Location: New Zealand
Posts: 1,134
Default

And while you are at it, service the ground cable connections from the battery->body->engine block. i.e. remove, clean both surfaces, lightly grease and replace. Grounding issues are an endless source of frustration in Peugeots...
WillNZ is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:31 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.