Peugeot 207 HDI 1.4 Poor acceleration under 2000 rpm - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-04-17, 11:08 AM   #1
Inactive User
 
Join Date: Apr 2017
Posts: 2
Default Peugeot 207 HDI 1.4 Poor acceleration under 2000 rpm

Hello,
Peugeot 207 HDI 1.4 2010 model (without FAP)

The above car is excellent apart from a very slow pick up below 2000 rpm, particularly noticeable in 1st and 2nd gears. It seems to wait 2, 3, and sometimes 4 seconds, before it suddenly races forward, when the revs get above 2000 rpm.

I would have thought this would be related to turbo problem issues, but would appreciate suggestions from anyone who may have had a similar problem and found a solution.

The car does 53 miles / gallon (which is great), and this is driving in towns and cities, so possibly there is a considerable carbon build up in the EGR valve and other places.
However even racing the engine (once fully warmed up) down the motorway to clear the carbon deposits, does not resolve the problem of sluggishness under 2000 rpm. The turbo lag seems too long to be working correctly.

There are no engine fault warning lights, and the exhaust emissions are "clean" (no black smoke).

Thank you
rjmcculloch is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-04-17, 12:12 PM   #2
Senior Member
 
Join Date: Feb 2016
Location: Thackley, West Yorks
Posts: 1,825
Default

I'd suggest getting live data whilst the car is running to see what's happening in "real time"
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimmymarsbar is offline   Reply With Quote Quick reply to this message
Old 04-04-17, 12:52 PM   #3
Inactive User
 
Join Date: Apr 2017
Posts: 2
Default

Thank you for your suggestion jimmymarsbar , but unfortunately I do not have a diagnostic interface.
rjmcculloch is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:26 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.