Peugeot 207 Fan controller only works on 4 and it makes a loud noise - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-08-19, 11:13 AM   #1
Junior Member
 
Join Date: Aug 2019
Posts: 2
Default Peugeot 207 Fan controller only works on 4 and it makes a loud noise

Hi All

My Peugeot 207 Fan controller only works on 4 and it makes a loud noise. I've uploaded a video to youtube showing what is happening

youtube.com/watch?v=NeWpoHSjgyE&feature=youtu.be

Someone at work said it might be

a) Fan Controller Resistor
b) Heater Fan Blower Motor

By looking at the video do you thing it is these two issues or something else? Both of these parts are reasonably priced on Ebay and I may try to fix them myself and save me 100's. Is it something a technical person could do?

I hope you can help
Colin
UK123CE is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-08-19, 12:15 PM   #2
Senior Member
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,905
Default

My son bought a 207 a couple of years ago with the same problem. I ordered a heater resistor from ebay and got him to replace it himself. My son isn't very technical but with very little guidance he was able to complete the job and had a fully working heater.

The job isn't technically dificult but the resistor is very awkward to get to.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is offline   Reply With Quote Quick reply to this message
Old 06-08-19, 12:27 PM   #3
Junior Member
 
Join Date: Aug 2019
Posts: 2
Default

I will give it a try. There are some good video showing you how to replace it and the part is only 14.95 on Ebay

My second issue is the load noise which I think is the Fan Blower Motor.

Thanks !
UK123CE is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:56 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.