Glowplug pigtail - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-09-18, 08:06 AM   #1
Junior Member
 
Join Date: Aug 2018
Posts: 5
Default Glowplug pigtail

Hi
I have a 2009 207 1.6HDI 90 van. It's done about 130k miles.
It always used to start really quickly, but now takes about a second or more. I know that doesn't sound much, but is it indicating a fault somewhere?
On its recent service, the glow plug relay was changed. My OBD reader always shows a glow plug relay fault, even after attempting to clear it.
Also, the dash never shows the pigtail. To be honest, I don't even know if and where this indicator is.
I also read that the glowplugs only really help for a very cold engine, like sub-zero.
Has anyone got a picture of where the pigtail indicator should be? Ta.
GraemeP is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-09-18, 09:52 AM   #2
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,156
Default

Its not glowplugs they only work when temps are in the minuses
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 02-09-18, 10:15 AM   #3
Moderator
 
noddy-hol's Avatar
 
Join Date: Jul 2013
Location: huntingdon.ish
Posts: 2,197
Default

Hi...could be the first signs of the battery starting to weaken..so its not cranking fast enough....or a starter showing its age.Will be worth checking both...ie votage while at rest and then when cranking will test the battery...let us know?
noddy-hol is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:28 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.