Battery problems on 207 - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Like Tree4Likes
  • 1 Post By s4td
  • 3 Post By hargaR1

Reply
 
LinkBack Thread Tools Display Modes
Old 30-05-19, 09:08 PM   #1
Junior Member
 
1welshwizard's Avatar
 
Join Date: Feb 2018
Location: Suffolk
Posts: 21
Default Battery problems on 207

My son broke down tonight in his Peugeot 207 1.4 2010.
As he was driving and talking via the cars hands free he ended the call and it seemed to still show the call was not disconnected on the cars screen so he pulled over to the side of the road and lowered the drivers window down and turned the engine off and back on to see if it would clear. The car was dead to his amazement the cars instrumental panel wouldn’t light up and there was a continuous intermittent clicking noise coming from around the passenger side glove box area. The lock button in the centre dashboard was slightly flashing weakly off and on. He awaited recovery and when they arrived the put some jump leads on the battery and it fired up straight away. He drove back home and as soon as he turned the engine off the same thing happened again the fault returned . The recovery driver mentioned to my son that the battery was knackered. I have checked the battery and it’s reading 12.8v . I am totally lost. Do I go and buy a new battery or could this be something else.
Many thanks in advance
Richard

Last edited by 1welshwizard; 30-05-19 at 09:29 PM.
1welshwizard is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 31-05-19, 08:09 AM   #2
Member
 
Join Date: Jul 2018
Posts: 33
Default

Sounds like a battery to me - try and see how you get on with a good charge especially if the car only does short trips.

Get it running and see what the voltage reading is- eliminate the alternator issues first.

You could get the battery tested most garages can do a drop test on them before you shell out for a new battery. Should not cost much if anything. I used kwik fit to test my battery but now I have my own tester.

If you are buying a new battery make sure is the same (or higher) CCA rated one.

Hope this helps
1welshwizard likes this.
s4td is offline   Reply With Quote Quick reply to this message
Old 31-05-19, 03:40 PM   #3
Junior Member
 
1welshwizard's Avatar
 
Join Date: Feb 2018
Location: Suffolk
Posts: 21
Default The outcome

I took the battery off last night and took it to a battery centre near were I live and yes the battery is Knackered. Although it was reading 12.8v with my multimeter it was only pushing out 1amps ��. The battery on the car was the original from when the car was new. 61 later and a New Yuasa battery the car is running fine again now. I thought I would plug my Delphi diagnostic into the car and clear any unwanted fault codes. Seemed to clear all apart from 1 code which is P0598 ? The car seems to run a lot smoother and a bit pokier.
1welshwizard is offline   Reply With Quote Quick reply to this message
 
Old 31-05-19, 03:54 PM   #4
Member
 
Join Date: Dec 2014
Location: Melbourne, Australia
Posts: 78
Default

A good battery would surly blow or melt a standard multimeter, if you tried to check amps!!
The Voltage may read at 12.8 volts but that doesn't measure Amps, cold cranking amps needs specialised equipment, and 1 amp would not be enough to turn your starter motor over. You are probably lucky the battery is knackered as a good battery would have most likely burnt your hands checking amps with a multi meter, most are only rated to 10 amps

Old school Battery testers that have an Amp shorting tester work the best IMO.

terry57, 1welshwizard and s4td like this.
__________________
Peugeot 207cc, 207XT, 206cc, PP2000 owner
hargaR1 is offline   Reply With Quote Quick reply to this message
Old 31-05-19, 08:49 PM   #5
Junior Member
 
1welshwizard's Avatar
 
Join Date: Feb 2018
Location: Suffolk
Posts: 21
Default

I only checked the voltage of the battery with my multimeter. It was the battery centre who properly checked the voltage and clarified that the battery was only giving out 1 amps. I must say that there meter was half the size of the one you show in the photo

Last edited by 1welshwizard; 31-05-19 at 10:00 PM.
1welshwizard is offline   Reply With Quote Quick reply to this message
Old 01-06-19, 03:43 PM   #6
Member
 
Join Date: Jul 2018
Posts: 33
Default

Quote:
Originally Posted by 1welshwizard View Post
I only checked the voltage of the battery with my multimeter. It was the battery centre who properly checked the voltage and clarified that the battery was only giving out 1 amps. I must say that there meter was half the size of the one you show in the photo

Glad to hear its sorted
s4td is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:37 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.