Airbag module fault? - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 29-04-15, 10:01 PM   #1
Inactive User
 
Join Date: Mar 2015
Posts: 4
Default Airbag module fault?

Hi, I have a Peugeot 207 HDI 90 and for a while now I have had an issue with an airbag warning coming on when somebody is sat in the passenger seat.

When the seat is empty no warning message pops up, when somebody is sat in the seat the car makes a 'bleep' and this message pops up:


The passenger seat light also never shows up, this picture was taken with nobody sat in any seat and all seatbelts unplugged, as you can see the passenger seat light is off:


Unsure if relevant but I believe this is a warning light and it comes on when I turn the ignition:


I took my car to a garage and they believe it is a fault with the SRS airbag module, this will cost me 200+ and it seems only a Peugeot mechanic can install it?

I just want to check if anybody on here has come across this fault before and if it sounds like its likely to be a fault with the airbag module before I spend a large amount of money repairing it.

Thanks!
kingsolo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 29-04-15, 10:26 PM   #2
Inactive User
 
Join Date: Oct 2013
Posts: 173
Default

Need to get codes read first really, though it sounds like the semsor in the passenger seat is at fault
joe366 is offline   Reply With Quote Quick reply to this message
Old 29-04-15, 10:29 PM   #3
Senior Member
 
greegor's Avatar
 
Join Date: Sep 2013
Location: Hove East Sussex
Posts: 822
Default

get a planet read done, but to me more likely to be wiring under the seat.
__________________
2008 feline 115 hdi. Life's a bitch so enjoy it!
greegor is offline   Reply With Quote Quick reply to this message
 
Old 30-04-15, 09:59 AM   #4
Inactive User
 
Join Date: Mar 2015
Posts: 4
Default

I was checked the wires under the passenger seat and I noticed that when I unplugged and reconnected the yellow connector, the next time I turned the electrics on the passenger seat light would show up, but then if I turned the electrics off and back on it wouldn't. This happened every time I unplugged and reconnected that yellow connector. Not sure if this means anything?
kingsolo is offline   Reply With Quote Quick reply to this message
Old 30-04-15, 10:03 AM   #5
Senior Member
 
greegor's Avatar
 
Join Date: Sep 2013
Location: Hove East Sussex
Posts: 822
Default

Personally I think you have bad connections under the seat.
unplug it and re connect, turn ignition on so lights show, then wiggle the wires to see if fault appears.
__________________
2008 feline 115 hdi. Life's a bitch so enjoy it!
greegor is offline   Reply With Quote Quick reply to this message
Old 30-04-15, 12:23 PM   #6
Inactive User
 
Join Date: Mar 2015
Posts: 4
Default

I've given this a try and it doesn't seem to trigger any errors, I'm going to take it to another garage next week to see what they say, seems like its a tricky one to find!
kingsolo is offline   Reply With Quote Quick reply to this message
Old 30-04-15, 12:35 PM   #7
Senior Member
 
greegor's Avatar
 
Join Date: Sep 2013
Location: Hove East Sussex
Posts: 822
Default

Have you looked at the planet map on here to see where the nearest member is with pp2000?
__________________
2008 feline 115 hdi. Life's a bitch so enjoy it!
greegor is offline   Reply With Quote Quick reply to this message
Old 30-04-15, 02:05 PM   #8
Moderator
 
Gibbo's Avatar
 
Join Date: Apr 2011
Location: Southport
Posts: 11,657
Default

https://www.peugeotforums.com/forums/...gnostic-28190/


https://www.peugeotforums.com/forums/...70/#post529130
__________________
Planet Diags: Sefton - Merseyside
Gibbo is offline   Reply With Quote Quick reply to this message
Old 30-04-15, 09:25 PM   #9
Senior Member
 
storeman's Avatar
 
Join Date: Jan 2013
Location: Oldham, UK
Posts: 5,906
Default

Has the car got a switch to disable the passenger airbag ?
Does the fault show if you fasten the seatbelt without anyone in the seat ?

It's possible the airbag could be disabled or the switch is faulty and only shows up when the seatbelt is used.

I accidentally switched my passenger airbag off and got warnings all the time.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
storeman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:22 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.