207 washer pump nightmare! - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-06-15, 04:40 PM   #1
Inactive User
 
Join Date: Jun 2015
Posts: 2
Default 207 washer pump nightmare!

Hi all,

I have a 207 2011 Envy, driving home last weekend when the ABS warning light came on and then the power steering and brake warning lights! Took to local Peugeot dealer (didn't buy the car there but they were the original seller of my car). Have been quoted 2670.46 to fix problem they found!!!

The washer pump has leaked and water from this has got into the fuse board. Needs new washer pump, wiring loom and fuse box. I nearly passed out at the cost!

Having had a quick look on here it seems a regular problem with 207? As this appears to be a fault in a car that is barely 4 years old is this something I should go back to Peugeot about and should they foot the cost?!!
mcvine82 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-06-15, 04:53 PM   #2
Inactive User
 
Join Date: May 2015
Location: Wirral
Posts: 364
Default

There are threads on here where people have gone back to Peugeot over this issue. In some cases Peugeot have apparently offered to supply the materials free of charge but no one has reported getting the labour free as of yet but yes if something is looking like a design/manufacturing fault it is always worth tackling the manufacturer as a lot will make goodwill gestures. Hope this helps.

Last edited by renegade; 07-06-15 at 05:05 PM.
renegade is offline   Reply With Quote Quick reply to this message
Old 08-06-15, 04:36 PM   #3
Senior Member
 
erick-r's Avatar
 
Join Date: Jan 2015
Location: Mexico City
Posts: 361
Default

Your engine is 1.4? I think is the only affected by that failure.

See these two threads:

https://www.peugeotforums.com/forums/...oom-ecu-66537/
https://www.peugeotforums.com/forums/...ng-loom-23762/

As you'll see, at least it's possible to get a refund of parts from peugeot, better than nothing :/

erick
erick-r is offline   Reply With Quote Quick reply to this message
 
Old 08-06-15, 05:07 PM   #4
Senior Member
 
Join Date: Jul 2012
Location: Devon
Posts: 134
Default

Same fault happened to my 1.6 HDI Sportium. This is where I wrote about it at the time............

https://www.peugeotforums.com/forums/...hlight=%A31550

Last edited by mattalsop; 08-06-15 at 05:11 PM.
mattalsop is offline   Reply With Quote Quick reply to this message
Old 10-06-15, 05:59 PM   #5
Inactive User
 
Join Date: Jun 2015
Posts: 2
Default

Thank you for replies, yes my car is a 1.4 engine. Have contacted my local dealer and waiting to hear back so keeping my fingers crossed!
mcvine82 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:49 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.