207 sw non starter - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 17-06-19, 12:01 PM   #1
Junior Member
 
Join Date: Jun 2019
Posts: 3
Default 207 sw non starter

Hi. I'm new here I'm not very knowledgable about cars, but I'm hoping I might be able to learn from some of you guys!
My husband bought a 59 plate Peugeot 207 SW (1.6 Diesel) at the beginning of the year, which has been great... until yesterday. It was fine one minute, then just didn't start any more! He drove over to our house from the car park over the road, stopped, myself and son got in, went to restart car and nothing happened. Engine isn't turning over. We changed the battery, as we weren't sure how old the existing one was, but still nothing!
Driver's side window is now stuck open, because the controls won't work. When key is in ignition display says ECONOMY MODE, and the battery light flashes.
I've had a look at the fuses, but the fuse board doesn't look the same as the layout in the manual, so I'm not sure which is for what, and with my lack of knowledge I don't want to go messing around!
I do (hopefully) have a mechanic coming to have a look later, but if anyone can offer any help or advice, it would be much appreciated
Thank you.
Cat87 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 17-06-19, 01:02 PM   #2
Junior Member
 
Join Date: Feb 2019
Posts: 10
Default

Just a couple of questions -

1 - when you try turn over do you hear a click from passenger side as rekey operates?

2- have you turned off. Leave for 5 min then turn ignition on then immediately try to close window before economy mode kicks in? This should let you know if BSI is ok. Till you get rid of economy mode itíll be difficult to do full reset

3 - check main earth leads they should attach to top of gearbox if I recall ( in work at mo so canít double check) and theyíre not loose or corroded

4 - have you tried bump start ? The car wonít reset the economy mode till it detects the car running , only other way to reset is via diagnostic software




Sent from my iPhone using Tapatalk
dcgpx is offline   Reply With Quote Quick reply to this message
Old 17-06-19, 01:34 PM   #3
Junior Member
 
Join Date: Jun 2019
Posts: 3
Default

Hi dcgpx
No click from passenger side.
We tried bump starting, with no luck!
I just tried closing the window, but that didn't work.
I'll see if I can have a look at the earth leads in a bit.
I also followed a YouTube video on how to reset the BSI, but sadly that was not fruitful, either! I'm guessing because the engine isn't actually running...

Thank you for taking time to reply to me
Cat87 is offline   Reply With Quote Quick reply to this message
 
Old 17-06-19, 01:56 PM   #4
Junior Member
 
Join Date: Feb 2019
Posts: 10
Default

Try checking fuses F1(20A). and F8 (25A) in the engine compartment fuse box

Only other thing I can think of is that the battery is still low so might be worth charging or jump leads to try see if itís that

BSI reset doesnít need engine running btw.

You could remove BSI and COMMS and then reseat but Iíd let mechanic do that if your not confident enough




Sent from my iPhone using Tapatalk
dcgpx is offline   Reply With Quote Quick reply to this message
Old 17-06-19, 02:20 PM   #5
Senior Member
 
Join Date: Oct 2012
Location: falkirk
Posts: 14,043
Default

Please read the economy mode thread most of your issues are relating to that removing battery and trying to reset the BSI may well have made your issue worse.

Its most likely fuse 8 in under bonnet fusebox that was your original issue or a broken earth under the bonnet everything else is BECAUSE its not starting.
__________________
assume nothing check everything twice !!
reliable406 is offline   Reply With Quote Quick reply to this message
Old 17-06-19, 04:08 PM   #6
Junior Member
 
Join Date: Jun 2019
Posts: 3
Default

Thank you dcgpx!
It was a fuse! Car is running again!
Cat87 is offline   Reply With Quote Quick reply to this message
Old 17-06-19, 04:32 PM   #7
Junior Member
 
Join Date: Feb 2019
Posts: 10
Default

Quote:
Originally Posted by Cat87 View Post
Thank you dcgpx!

It was a fuse! Car is running again!


Glad itís going again.

Iíd still check main earths for security and corrosion as fuses blow for a reason.

Wouldnít take long to check from battery to where it connects to engine/bodywork.

Iíd would as a matter of course check the connection on starter itself just in case thatís loose.

All in all a 15min job and add a spare fuse in glovebox for emergency get you home in case happens again in middle of nowhere !


Sent from my iPhone using Tapatalk
dcgpx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:37 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.