207 dead - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 19-04-13, 08:25 PM   #1
Inactive User
 
troytroy's Avatar
 
Join Date: Apr 2011
Location: weston super mare
Posts: 32
Default 207 dead

hi all i have a 2007 207 1.4 petrol it will not start ani pollution on display mil light is on turn key nothing? not even a click lights work nice and bright so battery not dead pug planet says not comunicating with engine ecu
any help much appriciated its not in economy mode????

Last edited by troytroy; 19-04-13 at 08:57 PM.
troytroy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 19-04-13, 10:29 PM   #2
davidireland
Guest
 
Posts: n/a
Default

Diagnostic check needed to read what fault is causing the warning on dash. Get a proper Diagnostic done with Peugeot diagnostic.

Sent from AutoGuide.com Free App
  Reply With Quote Quick reply to this message
Old 19-04-13, 11:07 PM   #3
Senior Member
 
bettyswollocks's Avatar
 
Join Date: Mar 2009
Location: Northern Ireland
Posts: 9,737
Default

Check fuses
bettyswollocks is offline   Reply With Quote Quick reply to this message
 
Old 20-04-13, 02:08 PM   #4
Inactive User
 
troytroy's Avatar
 
Join Date: Apr 2011
Location: weston super mare
Posts: 32
Default update

checked all fuses pp2000 keeps saying engine ecu failed to reply have all dash lights anti pollution on display mil light is on when you turn the key the glove box light goes out and i get a faint click from the fusebox checked all earths that i can find no problems there pp2000 is telling me to check transponder
ignition controlled +ve supply nto controllunit 1320
-battery +ve supply to control unit1320
what is 1320 and where ???
1.4 petrol 207 2007

Last edited by troytroy; 20-04-13 at 03:24 PM. Reason: add more detail
troytroy is offline   Reply With Quote Quick reply to this message
Old 20-04-13, 02:15 PM   #5
davidireland
Guest
 
Posts: n/a
Default

1320 is the engine ecu.
  Reply With Quote Quick reply to this message
Old 20-04-13, 03:17 PM   #6
Inactive User
 
troytroy's Avatar
 
Join Date: Apr 2011
Location: weston super mare
Posts: 32
Default update

thanks for the reply
i am getting nowhere fast here though
there seems to be no engine ecu showing up on pp2000
is there a relay that powers the engine ecu pp is telling me to clear mil light and start the car but if i cant get the ecu to show then i cant clear the mil light and read the codes in engine ecu
all other ecu,s are showing but the one i really need to clear or read codes is the engine ecu controlled by the bsi from

Last edited by troytroy; 20-04-13 at 03:25 PM.
troytroy is offline   Reply With Quote Quick reply to this message
Old 20-04-13, 03:32 PM   #7
davidireland
Guest
 
Posts: n/a
Default

It is via a CAN wire. You'll have to check the lives and earths to the engine ecu to be sure. Did you check the connectors on the ecu? Take them off and check the pins for coolant ingress.

Sent from AutoGuide.com Free App
  Reply With Quote Quick reply to this message
Old 20-04-13, 03:49 PM   #8
Inactive User
 
troytroy's Avatar
 
Join Date: Apr 2011
Location: weston super mare
Posts: 32
Default thanks

david thanks again for the reply im not a mecanic so please bear with
there are 3 plugs on the engine ecu
i have pulled all three off they seem fine there are about 50 wires or so within the 3 plugs how do i check the lives and earths are they coulor coded it is just like there is a fuse or relay that gives power to the ecu thats up the spout if i could get in to the engine ecu on peugeot planet i could try to put the mill light out and read codes but i cant get the blo*&^ thing to comunicate as it seems to have no power going to it if the ecu has no feedor is us woulkd this stop it even turning over as all i get when i try to start it is the light in the glove box goes out not even a click from the starter

thanks again
troytroy is offline   Reply With Quote Quick reply to this message
Old 20-04-13, 03:53 PM   #9
davidireland
Guest
 
Posts: n/a
Default

Have you tried disconnecting the battery for a while. Checking the lives and earths is only done with a wiring diagram of your cars wiring. Well it makes it easier to know where all the wires are going. Peugeot dont go by colour codes, its all wire number.
Best take that car to a dealer. They'd have the wiring checked in that in an hour or so with the correct equipment.

Sent from AutoGuide.com Free App
  Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 12:36 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.