207 1.6 HDI Fuel filter issue - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 207
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-05-15, 06:05 PM   #1
Inactive User
 
toneil461's Avatar
 
Join Date: Jun 2013
Posts: 66
Default 207 1.6 HDI Fuel filter issue

Just completed a service on my wifes 2011 207 cc 1.6 GT fitted with a HDI engine. I replaced the fuel filter (FRAM P11047) and could not start vehicle. As it does'nt have a manual prime pump, I turned the ignition on/off 10 times to purge fuel system but to no avail.

I put the old filter back on (OE) and repeated the above procedure and the vehicle started and run OK. Put the FRAM back on repeated the above procedure and again vehicle would not start. Old fuel filter back on and vehicle up and running with no problems.

I have replaced many fuel filters in my time and have not experienced this before especially with FRAM filters.

Contacted my supplier they said this is very unusual and are unaware of any issues but will replace the unit FOC. Can anyone shed any light on this??

Kind regards
Terry..
toneil461 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-05-15, 07:02 PM   #2
Inactive User
 
Join Date: Oct 2013
Posts: 173
Default

Ignition off/on won't do anything as there isn't a pump in the tank, have you filled the new filter with diesel before fitting it?
joe366 is offline   Reply With Quote Quick reply to this message
Old 06-05-15, 08:10 PM   #3
Inactive User
 
toneil461's Avatar
 
Join Date: Jun 2013
Posts: 66
Default

Fuel filter filled priior to fitting. How do I prime the fuel upto the filter?. There is no prime pump fitted. The method I used got the old filter up and running. Am I missing something here??
toneil461 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:25 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.