Rear brake cluster lights not working - But high light is? - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Models > 106
PeugeotForums.com is the premier Peugeot All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-12-14, 08:39 AM   #1
Inactive User
 
Join Date: Dec 2013
Posts: 27
Default Rear brake cluster lights not working - But high light is?

Morning All,

As stated in the title really, My brake lights in my clusters arent working, but the light at the top of the rear screen works??

I thought it may be the fuse, but surely that would take out all three lights?

I haven't checked the bulbs yet, but for both to go together its a bit odd is it not??

Thanks
Ross
Rosco88 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-12-14, 10:32 AM   #2
Senior Member
 
Join Date: Aug 2012
Location: Margate UK
Posts: 1,062
Default

No, maybe one had failed some time ago.
Anyway checking the bulbs is easy, always the first step if a light doesn't work.

Roger.
__________________
Keeping clunkers out of junkyards.
rustyroger is offline   Reply With Quote Quick reply to this message
Old 12-12-14, 11:40 AM   #3
Senior Member
 
Old Pug's Avatar
 
Join Date: Apr 2014
Location: Berkshire
Posts: 863
Default

I think you will find water inside the lamps and the bulb holders all corroded???
Old Pug is offline   Reply With Quote Quick reply to this message
 
Old 28-02-15, 09:51 PM   #4
Inactive User
 
Join Date: Apr 2014
Posts: 30
Default

I'd say it's a fuse, do reverse lights and indicators work? If now it's a fuse


Sent from my cracking iPad
106steve is offline   Reply With Quote Quick reply to this message
Old 07-03-15, 12:33 PM   #5
Inactive User
 
Join Date: Mar 2014
Location: Just outside Belfast
Posts: 177
Default

I'd go for bulbs, especially as the hi level brake light is working.
andy308sw is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:27 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.