Peugeot depollution / additive system fault - Peugeot Forums
Peugeot Forums - Peueot - Citroen Community
Home :: Peugeot Forums :: Rules :: Articles :: About Us :: Partner Vendors :: Advertise


Go Back   Peugeot Forums > Peugeot Tuning & Modifications > Maintenance
PeugeotForums.com is the premier Peugeot Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-11-09, 05:03 PM   #1
Junior Member
 
Join Date: Nov 2009
Posts: 3
Default Peugeot depollution / additive system fault

Hello, I am new to this forum and looking for some help to fix my pug. Any help is welcome and I want to share my information as well.

Iíve got Peugeot 407 2.0 HDI with the depollution system faulty. Since that fuel consumption a bit increased and reveres sometimes dropping. After scanning with OBD2 scanner the following faults codes been found

P1435 Ė Additive system fault (unfortunately I canít scan additive ECU)
P0461 - Fuel Level Sensor Performance
P2408 - Fuel Cap Sensor

After cleaning fault codes P1435 only comes on after engine start, but after few more starts and other two comes again.
I did research and it is linked to additive system. Is P2408 relative to P1435?

I noticed when I remove the fuel cap (both magnets present) and put it back the additive system pump starts work in about 5min and fluid goes to the fuel tank (as I have disconnected additive fluid pipe from fuel tank to check) is it mean that fuel filler cap sensor and cap is not faulty? So why Iíve got P2408? Or it is need replacing anyway
Also I have removed and checked additive system tank and itís half full of fluid, so do not need to top up.

The other thing where is fuel level sensor in this model? Is it possible to replace it separately or it is integrated in fuel tank?

Does anyone have any ideas? Thanks
Artur99 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-11-09, 02:07 PM   #2
Junior Member
 
Join Date: Sep 2008
Posts: 2
Default

Hi!

I have a pug 407 1.6hdi dv6 and yesterday tested my pug scanner (Pug Planet 2k) From the info that i got with it, i think that it measures the weight of what's in the tank... I could be wrong, however it showed me that i have 0 gram of that additive, I didn't top up yet, so don't know if i'm right.

Hope that helps in some way...

Regards..
denis_st is offline   Reply With Quote Quick reply to this message
Old 09-11-09, 10:36 AM   #3
Junior Member
 
Join Date: Nov 2009
Posts: 3
Default

hi just for update, the multiplay fault seems caused by additive ecu fault.
does anyone know where is additive ecu in 407 2.0 hdi?
Artur99 is offline   Reply With Quote Quick reply to this message
Old 09-11-09, 10:39 AM   #4
Junior Member
 
Join Date: Nov 2009
Posts: 3
Default

Quote:
Originally Posted by denis_st
Hi!

I have a pug 407 1.6hdi dv6 and yesterday tested my pug scanner (Pug Planet 2k) From the info that i got with it, i think that it measures the weight of what's in the tank... I could be wrong, however it showed me that i have 0 gram of that additive, I didn't top up yet, so don't know if i'm right.

Hope that helps in some way...

Regards..
hi,

fuel sensor measures FUEL level in the fuel tank and it different to additive fluid tank which has integrated sensor. you probably run out of additive fluid, so need to top up 3 liters and reset additve system counters.
Artur99 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Peugeot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:34 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0